summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2024-04-20 09:13:05 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2024-04-20 09:18:53 -0500
commit63dede62a231810ba4c5a4577536f3861f07ff66 (patch)
tree6a5da3c658a9ab422d41a2d517e65646bd6c9d73 /app-admin/ansible/ansible-9.4.0.ebuild
parentapp-admin/ansible-core: add 2.16.6 (diff)
downloadgentoo-63dede62a231810ba4c5a4577536f3861f07ff66.tar.gz
gentoo-63dede62a231810ba4c5a4577536f3861f07ff66.tar.bz2
gentoo-63dede62a231810ba4c5a4577536f3861f07ff66.zip
app-admin/ansible: add 9.4.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/ansible/ansible-9.4.0.ebuild')
-rw-r--r--app-admin/ansible/ansible-9.4.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/ansible/ansible-9.4.0.ebuild b/app-admin/ansible/ansible-9.4.0.ebuild
new file mode 100644
index 000000000000..51baea072b8f
--- /dev/null
+++ b/app-admin/ansible/ansible-9.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86 ~x64-macos"
+RESTRICT="test"
+
+RDEPEND=">=app-admin/ansible-core-2.16.0
+ <app-admin/ansible-core-2.17"
+
+python_compile() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+python_install() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_install
+}