summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/apg/apg-2.3.0b-r5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/apg/apg-2.3.0b-r5.ebuild')
-rw-r--r--app-admin/apg/apg-2.3.0b-r5.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-admin/apg/apg-2.3.0b-r5.ebuild b/app-admin/apg/apg-2.3.0b-r5.ebuild
new file mode 100644
index 000000000000..07375890cbde
--- /dev/null
+++ b/app-admin/apg/apg-2.3.0b-r5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Another Password Generator"
+HOMEPAGE="http://www.adel.nursat.kz/apg/"
+SRC_URI="http://www.adel.nursat.kz/apg/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 hppa ppc ~ppc64 x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="cracklib"
+
+DEPEND="cracklib? ( sys-libs/cracklib )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ chmod -R 0700 "${S}"
+ if use cracklib; then
+ epatch "${FILESDIR}"/${P}-cracklib.patch
+ epatch "${FILESDIR}"/${PN}-glibc-2.4.patch
+ fi
+ epatch "${FILESDIR}"/${P}-crypt_password.patch
+}
+
+src_compile() {
+ sed -i 's,^#\(APG_CS_CLIBS += -lnsl\)$,\1,' Makefile \
+ || die "Sed failed"
+ if [[ ${CHOST} == *-darwin* ]]; then
+ sed -i 's,^APG_CLIBS += -lcrypt,APG_CLIBS += ,' Makefile \
+ || die "Sed failed"
+ fi
+
+ emake \
+ FLAGS="${CFLAGS} ${LDFLAGS}" CFLAGS="${CFLAGS} ${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ standalone || die "compile problem"
+ emake FLAGS="${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)" \
+ -C bfconvert || die "compile problem"
+}
+
+src_install() {
+ dobin apg apgbfm bfconvert/bfconvert || die
+ dodoc CHANGES INSTALL README THANKS TODO || die
+ cd doc
+ doman man/apg.1 man/apgbfm.1 || die
+ dodoc APG_TIPS pronun.txt rfc0972.txt rfc1750.txt || die
+}