summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-13 19:56:02 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-13 19:59:22 -0500
commit615570f30d1d97a41f19994dbe1d5f67fcdae9d0 (patch)
treedcbeb0df040464b11411754aa83d280586704dad /app-admin/augeas/augeas-1.12.0.ebuild
parentmedia-sound/pulseeffects: 4.5.9 stable amd64 (diff)
downloadgentoo-615570f30d1d97a41f19994dbe1d5f67fcdae9d0.tar.gz
gentoo-615570f30d1d97a41f19994dbe1d5f67fcdae9d0.tar.bz2
gentoo-615570f30d1d97a41f19994dbe1d5f67fcdae9d0.zip
app-admin/augeas: 1.12.0 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/augeas/augeas-1.12.0.ebuild')
-rw-r--r--app-admin/augeas/augeas-1.12.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-admin/augeas/augeas-1.12.0.ebuild b/app-admin/augeas/augeas-1.12.0.ebuild
new file mode 100644
index 000000000000..b40ea12be532
--- /dev/null
+++ b/app-admin/augeas/augeas-1.12.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A library for changing configuration files"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="http://download.augeas.net/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs test"
+
+RDEPEND="
+ dev-libs/libxml2
+ sys-libs/readline:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=app-doc/NaturalDocs-1.40
+ test? ( dev-lang/ruby )"
+
+PATCHES=(
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # selinux needs to implemented
+ econf \
+ --without-selinux \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ addpredict /usr/share/NaturalDocs/Config/Languages.txt
+ addpredict /usr/share/NaturalDocs/Config/Topics.txt
+ default
+}
+
+src_install() {
+ default
+ use static-libs || find "${D}" -name '*.la' -delete || die
+}