summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/aws-elb-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/aws-elb-tools')
-rw-r--r--app-admin/aws-elb-tools/Manifest1
-rw-r--r--app-admin/aws-elb-tools/aws-elb-tools-1.0.15.1.ebuild61
-rw-r--r--app-admin/aws-elb-tools/metadata.xml7
3 files changed, 69 insertions, 0 deletions
diff --git a/app-admin/aws-elb-tools/Manifest b/app-admin/aws-elb-tools/Manifest
new file mode 100644
index 000000000000..3f85d0af84e7
--- /dev/null
+++ b/app-admin/aws-elb-tools/Manifest
@@ -0,0 +1 @@
+DIST ElasticLoadBalancing-1.0.15.1.zip 6717939 SHA256 4b1f25de9be87ae1340426de58d966712b86baadd947ee9014d03784bcc0b5a7 SHA512 813f00d632b483a5ec98632d830be4b02fc1bc71aa7bd845faa477f7d05bda7c801e5d83992c111dfc136bf5e1204bf96b00a1c24e5b19438decb356d0841725 WHIRLPOOL b7b4d0eb103c845c887525dd33b4308ee1553b46d3d709db1231cbd972824bc99264f4f48c1229620cb27ba75ae53b8e2255fd75fc1f5c0cf8473a74b95de4a9
diff --git a/app-admin/aws-elb-tools/aws-elb-tools-1.0.15.1.ebuild b/app-admin/aws-elb-tools/aws-elb-tools-1.0.15.1.ebuild
new file mode 100644
index 000000000000..1772852952de
--- /dev/null
+++ b/app-admin/aws-elb-tools/aws-elb-tools-1.0.15.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+DESCRIPTION="The API tools serve as the client interface to the Elastic Load Balancing web service"
+HOMEPAGE="http://aws.amazon.com/developertools/Amazon-EC2/2536"
+SRC_URI="mirror://sabayon/${CATEGORY}/ElasticLoadBalancing-${PV}.zip"
+
+S="${WORKDIR}/ElasticLoadBalancing-${PV}"
+
+LICENSE="Amazon"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND="virtual/jre"
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack ${A}
+ cd "$S"
+ find . -name '*.cmd' -delete || die
+}
+
+src_install() {
+ dodir /opt/${PN}
+ insinto /opt/${PN}/lib
+ doins -r "${S}"/lib/*
+ exeinto /opt/${PN}/bin
+ doexe "${S}"/bin/*
+
+ dodir /etc/env.d
+ cat - > "${T}"/99${PN} <<EOF
+AWS_ELB_HOME=/opt/${PN}
+PATH=/opt/${PN}/bin
+ROOTPATH=/opt/${PN}/bin
+EOF
+ doenvd "${T}"/99${PN}
+
+ dodoc "THIRDPARTYLICENSE.TXT"
+}
+
+pkg_postinst() {
+ ewarn "Remember to run: env-update && source /etc/profile if you plan"
+ ewarn "to use these tools in a shell before logging out (or restarting"
+ ewarn "your login manager)"
+ elog
+ elog "You need to put the following in your ~/.bashrc replacing the"
+ elog "values with the full path to your AWS credentials file."
+ elog
+ elog " export AWS_CREDENTIAL_FILE=/path/and_filename_of_credential_file"
+ elog
+ elog "It should contains two lines: the first line lists the AWS Account's"
+ elog "AWS Access Key ID, and the second line lists the AWS Account's"
+ elog "Secret Access Key. For example:"
+ elog
+ elog " AWSAccessKeyId=AKIAIOSFODNN7EXAMPLE"
+ elog " AWSSecretKey=wJalrXUtnFEMI/K7MDENG/bPxRfiCYzEXAMPLEKEY"
+}
diff --git a/app-admin/aws-elb-tools/metadata.xml b/app-admin/aws-elb-tools/metadata.xml
new file mode 100644
index 000000000000..c964a88f43ca
--- /dev/null
+++ b/app-admin/aws-elb-tools/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>lxnay@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>