summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-09-02 20:06:47 -0400
committerTim Harder <radhermit@gentoo.org>2016-09-02 20:06:47 -0400
commitbc5607b66a3f9df1607e6f9c077d111f08930a1a (patch)
treebdb689a9718358a846263cd7e6a21e4ff2e5b36a /app-admin/lnav/lnav-0.8.1.ebuild
parentapp-misc/binwalk: version bump to 2.1.1 (diff)
downloadgentoo-bc5607b66a3f9df1607e6f9c077d111f08930a1a.tar.gz
gentoo-bc5607b66a3f9df1607e6f9c077d111f08930a1a.tar.bz2
gentoo-bc5607b66a3f9df1607e6f9c077d111f08930a1a.zip
app-admin/lnav: version bump to 0.8.1
Diffstat (limited to 'app-admin/lnav/lnav-0.8.1.ebuild')
-rw-r--r--app-admin/lnav/lnav-0.8.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-admin/lnav/lnav-0.8.1.ebuild b/app-admin/lnav/lnav-0.8.1.ebuild
new file mode 100644
index 000000000000..045f6fe36ebe
--- /dev/null
+++ b/app-admin/lnav/lnav-0.8.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A curses-based tool for viewing and analyzing log files"
+HOMEPAGE="http://lnav.org"
+SRC_URI="https://github.com/tstack/lnav/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="unicode"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-db/sqlite:3
+ dev-libs/libpcre[cxx]
+ >=net-misc/curl-7.23.0
+ sys-libs/ncurses:0=[unicode?]
+ sys-libs/readline:0=
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS NEWS README )
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_with unicode ncursesw)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}