summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-12-17 08:45:03 +0100
committerUltrabug <ultrabug@gentoo.org>2018-12-17 12:25:42 +0100
commit7fd1e90884b5d5c2b326654c39dab1958ac1f70d (patch)
treee126a15ef78158c6d60c06c5b5795c7f6fa38cea /app-admin/mongo-tools/mongo-tools-3.6.9.ebuild
parentdev-db/mariadb-connector-c: fix pkg-config file install location (diff)
downloadgentoo-7fd1e90884b5d5c2b326654c39dab1958ac1f70d.tar.gz
gentoo-7fd1e90884b5d5c2b326654c39dab1958ac1f70d.tar.bz2
gentoo-7fd1e90884b5d5c2b326654c39dab1958ac1f70d.zip
app-admin/mongo-tools: bump to 3.6.9
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10651 Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
Diffstat (limited to 'app-admin/mongo-tools/mongo-tools-3.6.9.ebuild')
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.6.9.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/app-admin/mongo-tools/mongo-tools-3.6.9.ebuild b/app-admin/mongo-tools/mongo-tools-3.6.9.ebuild
new file mode 100644
index 000000000000..5cf7cbaadac3
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-3.6.9.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="https://www.mongodb.com"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="sasl ssl"
+
+RDEPEND="!<dev-db/mongodb-3.0.0"
+DEPEND="${RDEPEND}
+ dev-lang/go:=
+ net-libs/libpcap
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl:0= )"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+
+ # 1) ensure we use bash wrt #582906
+ # 2) do not substitute version because it uses git
+ sed -e 's@/bin/sh@/bin/bash@g' \
+ -e '/^sed/,+3d' \
+ -e '/^stty/d' \
+ -e '/^mv/d' \
+ -i build.sh || die
+
+ # build pie to avoid text relocations wrt #582854
+ # skip on ppc64 wrt #610984
+ if ! use ppc64; then
+ sed -i 's/\(go build\)/\1 -buildmode=pie/g' build.sh || die
+ fi
+}
+
+src_compile() {
+ local myconf=()
+
+ if use sasl; then
+ myconf+=(sasl)
+ fi
+
+ if use ssl; then
+ myconf+=(ssl)
+ fi
+
+ ./build.sh "${myconf[@]}" || die "build failed"
+}
+
+src_install() {
+ dobin bin/*
+}