summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-01-21 08:02:49 +0100
committerHans de Graaff <graaff@gentoo.org>2017-01-21 08:02:49 +0100
commit3828c66db18fc7ceae2c0c4396287de204e93046 (patch)
tree545e2a2dafe3b42b6365cb7b8b246e51538cd29b /app-admin/puppet-lint/puppet-lint-2.1.0.ebuild
parentsys-fs/lufis: restore stable keywords (diff)
downloadgentoo-3828c66db18fc7ceae2c0c4396287de204e93046.tar.gz
gentoo-3828c66db18fc7ceae2c0c4396287de204e93046.tar.bz2
gentoo-3828c66db18fc7ceae2c0c4396287de204e93046.zip
app-admin/puppet-lint: add 2.1.0
Drop x86 keyword due to a new test dependency on dev-ruby/rspec-json_expectations, bug 606664. Package-Manager: portage-2.3.0
Diffstat (limited to 'app-admin/puppet-lint/puppet-lint-2.1.0.ebuild')
-rw-r--r--app-admin/puppet-lint/puppet-lint-2.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-admin/puppet-lint/puppet-lint-2.1.0.ebuild b/app-admin/puppet-lint/puppet-lint-2.1.0.ebuild
new file mode 100644
index 000000000000..252731d49011
--- /dev/null
+++ b/app-admin/puppet-lint/puppet-lint-2.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit eutils ruby-fakegem
+
+DESCRIPTION="A linter for puppet DSL"
+HOMEPAGE="http://puppet-lint.com/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec-its:1
+ dev-ruby/rspec-collection_matchers:1
+ dev-ruby/rspec-json_expectations )"