summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2020-09-18 14:18:50 +0000
committerJason Zaman <perfinion@gentoo.org>2020-10-11 19:19:55 -0700
commit3875b472e5c7ae6459c9f86a743ee9c7ccc7504c (patch)
tree8375ccb0395b3975a5f72bd6d3712fcec9d93a89 /app-admin/selint/selint-9999.ebuild
parentdev-lua/lua-zlib: add myself as maintainer (diff)
downloadgentoo-3875b472e5c7ae6459c9f86a743ee9c7ccc7504c.tar.gz
gentoo-3875b472e5c7ae6459c9f86a743ee9c7ccc7504c.tar.bz2
gentoo-3875b472e5c7ae6459c9f86a743ee9c7ccc7504c.zip
app-admin/selint: Added new package with version 1.1.0.
Closes: https://github.com/gentoo/gentoo/pull/17588 Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'app-admin/selint/selint-9999.ebuild')
-rw-r--r--app-admin/selint/selint-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/selint/selint-9999.ebuild b/app-admin/selint/selint-9999.ebuild
new file mode 100644
index 000000000000..f79040712259
--- /dev/null
+++ b/app-admin/selint/selint-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Policy Analysis Tools for SELinux"
+HOMEPAGE="https://github.com/TresysTechnology/selint/wiki"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/TresysTechnology/selint.git"
+else
+ SRC_URI="https://github.com/TresysTechnology/selint/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/confuse
+ dev-libs/uthash"
+
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
+
+src_prepare() {
+ [[ ${PV} == 9999 ]] && eautoreconf
+
+ eapply_user
+}
+
+src_configure() {
+ econf $(use_with test check)
+}