summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Oberzalek <kingleo@gmx.at>2021-04-04 21:31:38 +0200
committerSam James <sam@gentoo.org>2021-04-05 15:04:55 +0000
commit8009b39933d27c43cea5b19c1ab2ebd3ced933d3 (patch)
tree9b11c8c04ad978a632232e978aded868e71663ae /app-admin/xstow/xstow-1.0.2.ebuild
parentmedia-libs/libpgf: remove .la file (diff)
downloadgentoo-8009b39933d27c43cea5b19c1ab2ebd3ced933d3.tar.gz
gentoo-8009b39933d27c43cea5b19c1ab2ebd3ced933d3.tar.bz2
gentoo-8009b39933d27c43cea5b19c1ab2ebd3ced933d3.zip
app-admin/xstow: Bumped to version xstow-1.0.2
update to EAP7, fixes EPREFIX glitches Assigned Martin Oberzalek as proxy maintainer Signed-off-by: Martin Oberzalek <kingleo@gmx.at> Package-Manager: Portage-3.0.18, Repoman-3.0.3 Closes: https://github.com/gentoo/gentoo/pull/20255 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin/xstow/xstow-1.0.2.ebuild')
-rw-r--r--app-admin/xstow/xstow-1.0.2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-admin/xstow/xstow-1.0.2.ebuild b/app-admin/xstow/xstow-1.0.2.ebuild
new file mode 100644
index 000000000000..3e3265167241
--- /dev/null
+++ b/app-admin/xstow/xstow-1.0.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="replacement for GNU stow with extensions"
+HOMEPAGE="http://xstow.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xstow/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ncurses"
+
+DEPEND="ncurses? ( sys-libs/ncurses:0= )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ncurses.patch
+)
+
+src_prepare() {
+ eautoreconf
+ default
+}
+
+src_configure() {
+ econf $(use_with ncurses curses)
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="${EPREFIX}/usr/share/doc/${PF}/html" install
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ # create new STOWDIR
+ dodir /var/lib/xstow
+
+ # install env.d file to add STOWDIR to PATH and LDPATH
+ doenvd "${FILESDIR}/99xstow"
+}
+
+pkg_postinst() {
+ elog "We now recommend that you use /var/lib/xstow as your STOWDIR"
+ elog "instead of /usr/local in order to avoid conflicts with the"
+ elog "symlink from /usr/lib64 -> /usr/lib. See Bug 246264"
+ elog "(regarding app-admin/stow, equally applicable to XStow) for"
+ elog "more details on this change."
+ elog "For your convenience, PATH has been updated to include"
+ elog "/var/lib/bin."
+}