summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-26 03:35:19 +0100
committerSam James <sam@gentoo.org>2022-09-26 03:35:19 +0100
commit4c94b0e2a1f279a1e19f8a393d4cf1e3d54f9a64 (patch)
treea9781d7c650422b22cfa71742132aad51494a63e /app-admin
parentnet-fs/nfs-utils: add link to upstream patch submission (diff)
downloadgentoo-4c94b0e2a1f279a1e19f8a393d4cf1e3d54f9a64.tar.gz
gentoo-4c94b0e2a1f279a1e19f8a393d4cf1e3d54f9a64.tar.bz2
gentoo-4c94b0e2a1f279a1e19f8a393d4cf1e3d54f9a64.zip
app-admin/watchfolder: fix implicit function decls
Closes: https://bugs.gentoo.org/870433 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/watchfolder/files/0.3.3-implicit-decl.patch14
-rw-r--r--app-admin/watchfolder/watchfolder-0.3.3-r2.ebuild (renamed from app-admin/watchfolder/watchfolder-0.3.3-r1.ebuild)2
2 files changed, 15 insertions, 1 deletions
diff --git a/app-admin/watchfolder/files/0.3.3-implicit-decl.patch b/app-admin/watchfolder/files/0.3.3-implicit-decl.patch
index 1b8e72d72bf8..f2fc0b367d48 100644
--- a/app-admin/watchfolder/files/0.3.3-implicit-decl.patch
+++ b/app-admin/watchfolder/files/0.3.3-implicit-decl.patch
@@ -38,3 +38,17 @@
#include <sys/wait.h>
#include <stdio.h>
#include <stdlib.h>
+diff --git a/watchd.c b/watchd.c
+index 842e186..49edb64 100644
+--- a/watchd.c
++++ b/watchd.c
+@@ -52,6 +52,9 @@ Syntax : watchd
+ #define FL_LOG_MAIL 256
+ #define FL_LOG_ALWAYS 512
+
++int isdir(char *name);
++void ini_close(inifile *i);
++
+ typedef struct Twatchfolder
+ {
+ char* runprg;
diff --git a/app-admin/watchfolder/watchfolder-0.3.3-r1.ebuild b/app-admin/watchfolder/watchfolder-0.3.3-r2.ebuild
index 1622add191e4..9a93d1579f8a 100644
--- a/app-admin/watchfolder/watchfolder-0.3.3-r1.ebuild
+++ b/app-admin/watchfolder/watchfolder-0.3.3-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7