summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-05 09:10:42 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-05 10:16:53 +0200
commit80f03e9ef946535e88b1de22fd673970589db2f1 (patch)
treea1826729e00dbcefefc84a9966bbe4583efc939a /app-admin
parentdev-python/boto3: Bump to 1.22.7 (diff)
downloadgentoo-80f03e9ef946535e88b1de22fd673970589db2f1.tar.gz
gentoo-80f03e9ef946535e88b1de22fd673970589db2f1.tar.bz2
gentoo-80f03e9ef946535e88b1de22fd673970589db2f1.zip
app-admin/awscli: Bump to 1.23.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.23.7.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index f230cbe98889..487ab3c01fdf 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -5,5 +5,6 @@ DIST aws-cli-1.23.3.gh.tar.gz 2200496 BLAKE2B 4c264c2e551af9df2f84d405a08f1e386d
DIST aws-cli-1.23.4.gh.tar.gz 2200991 BLAKE2B b70012a8dd83d46a460977063ad11111a7af728ee7e00f87cf5d559ff3e1a4eb1824580bfc5f869d749d0e75e336eb3a025a77f2b637a7306dc39fadba2382a1 SHA512 e949b4bf171e1ad4364ced1fbb7bec89d83077ee2de745dfc661fe1518476e7e07a29e58877adbe65c46398602af374d9af47ae976e7984b1ed2e59a67bd4f03
DIST aws-cli-1.23.5.gh.tar.gz 2201321 BLAKE2B 280b0390c0e0759c0c7809b86de5be9356df2d8e46b9048964b717f8bb2cf53db80fe3268fc897bd0d46e74bff473214851806c3e60ba101a9885b3fa2a6bf55 SHA512 b964c8ded99b4320ad3197cd40e4da9afdd774fbcac872aa37b09d21df882226b3e3ee54af8cceb02ecf0fd5803c9deb2d1e9733e75bf0e14a7010b5a46bab21
DIST aws-cli-1.23.6.gh.tar.gz 2201645 BLAKE2B 11bf1312acd59a813370f5b2f71e7b113241ea977d42e50765716ed50ec8d77307bd14fd4abd2404c2638e18ec92f38c815b5a89fbd63a08cc8e470dff6ce48c SHA512 d919749c4a228f87abf8e77e3ea6f3276a033698169c3244a583322148a2bc4dd93fd2c28a552a0130c0ee5139180bad286c241100beec160e815c5a01527fa0
+DIST aws-cli-1.23.7.gh.tar.gz 2201704 BLAKE2B 4c97a7bfc09c794afebd7c770bc1dcc98a8f1458597235bdde0a8236ce49f661cff6f7ab7f4c7eee85160432c5f991b18feab45568c6b5b84aa8eff9b11b0c18 SHA512 24173c1f2905bc005c2f02de69feadf21e78e38b569f9c0dcb72658a2ca1b0c3c621bf4a6d121be2388c40fcfb02423feb301b84d63b25ea384ffe1c0ddd8d37
DIST awscli-1.22.101.tar.gz 2196746 BLAKE2B 590938e722e9dff00bcdb4a266f7063bca4e890f5db5e52b56ed710f5777c6e9de3cfe1423cee9ae2cea74d624bdd665cd8af487aec1ba4e650279c700540545 SHA512 ab99b95c5252c48a7a1d10adb053c56e27139e35bb512ce854e90a433e2d028aed2a88f72e518b0f723dea147919961e7cc7f5d980342206e629f750b0fe77ec
DIST awscli-1.22.97.tar.gz 2193983 BLAKE2B f2e0efbb2332d4c405d5e97ba35426424d932a013114492890018d3419349e23aa3c8301f6c29bd8eaa662145b07ceaa30c22e41aad38012ca307400075600ca SHA512 00426aab19fcdf3241850b09d4d5dd6a1460e3ec9baa37cf203068dc6ca0fddd4fe3de7e4e93e8e6539608351777e00692bb8b9d2c362ceeacc55071cd53f422
diff --git a/app-admin/awscli/awscli-1.23.7.ebuild b/app-admin/awscli/awscli-1.23.7.ebuild
new file mode 100644
index 000000000000..acabee851193
--- /dev/null
+++ b/app-admin/awscli/awscli-1.23.7.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}