summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-18 07:23:56 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-18 08:20:08 +0100
commit8ccf4a124e7b190afd515ecd78fd45c39279be44 (patch)
treeba4ca30ad91ad2d8da4a1607bcca163b81b9189f /app-admin
parentdev-python/boto3: Bump to 1.36.2 (diff)
downloadgentoo-8ccf4a124e7b190afd515ecd78fd45c39279be44.tar.gz
gentoo-8ccf4a124e7b190afd515ecd78fd45c39279be44.tar.bz2
gentoo-8ccf4a124e7b190afd515ecd78fd45c39279be44.zip
app-admin/awscli: Bump to 1.37.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.37.2.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 7cda8bfcbed1..72daed24f361 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -5,3 +5,4 @@ DIST aws-cli-1.36.39.gh.tar.gz 2879615 BLAKE2B 54bed9cb8e5cb2d5f27178040a4f5f38f
DIST aws-cli-1.36.40.gh.tar.gz 2879864 BLAKE2B f6d8ae65edb2f3bb6f15376560f5ad93936f81b1a14d6573af011e9b4fb48552888f52a5b25a29237dc66d54802babec3bd9df640119b10c713b9de7dc6fe7d0 SHA512 1c0de5ff22cd5be7d33dbf0ae3fbe11d7eb5ced13773d8567dee3f57f62aaa7f135555234c659fd33ac0ae9e1c55f95e34ac0b1490e1b7f983ce9cc4a8953809
DIST aws-cli-1.37.0.gh.tar.gz 2881507 BLAKE2B 4c6fc8921304d8f4c9cf4ce760325be42c2f7b9f072946bba1bd9e9c4d9b28d4033c39bb69b553f6c7a3b07014091d1cffffb4cb9a40bbd22ec4410b06006199 SHA512 170ba977abb2b655346cb1c507126a341e830226f8844ac719c6c7e10c7962055df8c4ff667fde3aa595be518f481a7ed1b85e249f8991365df51c6201bc04f2
DIST aws-cli-1.37.1.gh.tar.gz 2881540 BLAKE2B 99dc9be76e0cb2a6052d630e5d87d56fde13a0fb1dc954b523e9ef8529f88234b47ab0eac02611dac2f40e7c38abf69983336e99e2ee8f9f7bc8c808e5f8ee1e SHA512 b48d1d0038ce400a1874c09c481569422211ef2d3894368a32e144fec130480bfbe31cbdecf107b632703ab2a4ee4028173d3a97f9ea2a7a0cef9cf80743cad9
+DIST aws-cli-1.37.2.gh.tar.gz 2882709 BLAKE2B be8e03342f8c105646c7a92bd9f4716952700cb1cee883669b532851f73b896dd3f55266851db0351348ca50e3d96ec78f296327545eaac1e5d4ceba58a71eeb SHA512 492ac75a47187a5579cae3211b7e4b9df34c7fcab8903cc52a61cc9dc6238f32268a04e45eb4edead76504636a85987355d4bf71f700df7c14dc215b45e8058b
diff --git a/app-admin/awscli/awscli-1.37.2.ebuild b/app-admin/awscli/awscli-1.37.2.ebuild
new file mode 100644
index 000000000000..4a8e0ae852e0
--- /dev/null
+++ b/app-admin/awscli/awscli-1.37.2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y-1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) - 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.11.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=(
+ "${serial_tests[@]}"
+
+ # flaky (some ordering?)
+ tests/functional/s3/test_cp_command.py::TestCPCommand::test_multipart_upload_with_checksum_algorithm_crc32
+ )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}