summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-07-27 07:55:49 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-07-27 08:09:15 -0400
commita4f7145c4c1f2c2c9910a3fc847cbfd84362f42c (patch)
tree671fb5bd13957ece75174674b406bc085079f112 /app-admin
parentsys-kernel/gentoo-kernel-bin: Bump to 5.10.223 (diff)
downloadgentoo-a4f7145c4c1f2c2c9910a3fc847cbfd84362f42c.tar.gz
gentoo-a4f7145c4c1f2c2c9910a3fc847cbfd84362f42c.tar.bz2
gentoo-a4f7145c4c1f2c2c9910a3fc847cbfd84362f42c.zip
app-admin/drush: add another compatibility patch
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/drush/drush-6.7.0-r8.ebuild (renamed from app-admin/drush/drush-6.7.0-r7.ebuild)1
-rw-r--r--app-admin/drush/files/drush-6.7.0-sql-dollar-sign.patch26
2 files changed, 27 insertions, 0 deletions
diff --git a/app-admin/drush/drush-6.7.0-r7.ebuild b/app-admin/drush/drush-6.7.0-r8.ebuild
index 1329345e4dc0..2768a8302b65 100644
--- a/app-admin/drush/drush-6.7.0-r7.ebuild
+++ b/app-admin/drush/drush-6.7.0-r8.ebuild
@@ -23,6 +23,7 @@ PATCHES=(
"${FILESDIR}/${P}-gzip-mime.patch"
"${FILESDIR}/${P}-dont-pass-null-to-strtoupper.patch"
"${FILESDIR}/${P}-batch-signature-fix-r1.patch"
+ "${FILESDIR}/${P}-sql-dollar-sign.patch"
)
src_prepare() {
diff --git a/app-admin/drush/files/drush-6.7.0-sql-dollar-sign.patch b/app-admin/drush/files/drush-6.7.0-sql-dollar-sign.patch
new file mode 100644
index 000000000000..9d6b37274a75
--- /dev/null
+++ b/app-admin/drush/files/drush-6.7.0-sql-dollar-sign.patch
@@ -0,0 +1,26 @@
+From ed5365ba0e6021d2dfbfe9b31bfd641d718eb978 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Sat, 27 Jul 2024 07:52:15 -0400
+Subject: [PATCH 1/1] commands/sql/sql.drush.inc: ${var} -> {$var}
+
+This fixes a deprecation warning with newer PHPs.
+---
+ commands/sql/sql.drush.inc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/commands/sql/sql.drush.inc b/commands/sql/sql.drush.inc
+index 6d7a4aa..fcf2654 100644
+--- a/commands/sql/sql.drush.inc
++++ b/commands/sql/sql.drush.inc
+@@ -1414,7 +1414,7 @@ function drush_sql_format_oracle($query) {
+ $sqlp_settings = implode("\n", $settings)."\n";
+
+ // important for sqlplus to exit correctly
+- return "${sqlp_settings}${query};\nexit;\n";
++ return "{$sqlp_settings}{$query};\nexit;\n";
+ }
+
+
+--
+2.44.2
+