summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-01-23 09:21:18 -0800
committerZac Medico <zmedico@gentoo.org>2017-01-23 09:22:28 -0800
commitf7986fe91c1531b78b50d4448e72248b6075fe81 (patch)
treef935dc6405dce686d72022c88e0e924358a26472 /app-admin
parentwww-client/chromium: add system-libvpx USE flag (diff)
downloadgentoo-f7986fe91c1531b78b50d4448e72248b6075fe81.tar.gz
gentoo-f7986fe91c1531b78b50d4448e72248b6075fe81.tar.bz2
gentoo-f7986fe91c1531b78b50d4448e72248b6075fe81.zip
app-admin/consul: avoid zip dependency
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/consul/consul-0.7.2.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-admin/consul/consul-0.7.2.ebuild b/app-admin/consul/consul-0.7.2.ebuild
index be5a8fce062b..7bbd099fe74b 100644
--- a/app-admin/consul/consul-0.7.2.ebuild
+++ b/app-admin/consul/consul-0.7.2.ebuild
@@ -22,7 +22,6 @@ IUSE=""
RESTRICT="test"
DEPEND="
- app-arch/zip
>=dev-lang/go-1.6:=
>=dev-go/go-tools-0_pre20160121"
RDEPEND=""
@@ -79,8 +78,11 @@ src_prepare() {
src_compile() {
export GOPATH="${S}"
go install -v -work -x ${EGO_BUILD_FLAGS} "github.com/mitchellh/gox/..." || die
- PATH=${PATH}:${S}/bin XC_ARCH=$(go env GOARCH) XC_OS=$(go env GOOS) \
- emake -C "${S}/src/${EGO_PN}"
+ # The dev target sets causes build.sh to set appropriate XC_OS
+ # and XC_ARCH, and skips generation of an unused zip file,
+ # avoiding a dependency on app-arch/zip.
+ PATH=${PATH}:${S}/bin \
+ emake -C "${S}/src/${EGO_PN}" dev
}
src_install() {