summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-07-29 18:46:47 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-07-31 18:11:45 +0000
commitd8d4a949b4d145d328b6a0faaf2cc1694c306912 (patch)
tree7eaac7bb22b0a9cf4b26459ae3264c459b84e1b6 /app-arch/brotli/files
parentdev-python/python-lzo: version bump (diff)
downloadgentoo-d8d4a949b4d145d328b6a0faaf2cc1694c306912.tar.gz
gentoo-d8d4a949b4d145d328b6a0faaf2cc1694c306912.tar.bz2
gentoo-d8d4a949b4d145d328b6a0faaf2cc1694c306912.zip
app-arch/brotli: initial import
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'app-arch/brotli/files')
-rw-r--r--app-arch/brotli/files/brotli-0.6.0-no-rpath.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-arch/brotli/files/brotli-0.6.0-no-rpath.patch b/app-arch/brotli/files/brotli-0.6.0-no-rpath.patch
new file mode 100644
index 000000000000..28e70d7acfe7
--- /dev/null
+++ b/app-arch/brotli/files/brotli-0.6.0-no-rpath.patch
@@ -0,0 +1,32 @@
+From: Tomasz Buchert <tomasz@debian.org>
+Date: Sat, 24 Jun 2017 14:40:16 +0200
+Subject: Do not set rpath on shared libs.
+
+---
+ CMakeLists.txt | 13 -------------
+ 1 file changed, 13 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ca612d1..bf70d69 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -27,19 +27,6 @@ CMAKE_DEPENDENT_OPTION(BUILD_SHARED_LIBS "Build shared libraries" ON "NOT BROTLI
+
+ include(GNUInstallDirs)
+
+-# When building shared libraries it is important to set the correct rpath.
+-# See https://cmake.org/Wiki/CMake_RPATH_handling#Always_full_RPATH
+-if (BUILD_SHARED_LIBS)
+- add_definitions(-DBROTLI_SHARED_COMPILATION)
+- set(CMAKE_SKIP_BUILD_RPATH FALSE)
+- set(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
+- set(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
+- list(FIND CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES "${CMAKE_INSTALL_LIBDIR}" isSystemDir)
+- if ("${isSystemDir}" STREQUAL "-1")
+- set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_LIBDIR}")
+- endif()
+-endif()
+-
+ # Parse version information from common/version.h. Normally we would
+ # define these values here and write them out to configuration file(s)
+ # (i.e., config.h), but in this case we parse them from