summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArturo R Ochoa <arturo340@outlook.com>2023-08-07 02:49:06 -0700
committerSam James <sam@gentoo.org>2023-08-13 07:49:26 +0100
commitfe77a8dc9b8f5c4b3f1194affdb7eb1246d06c4f (patch)
tree59c21bfa8a8350ed393e0216bbfd4cb65b2d21a1 /app-arch/createrepo_c
parentmedia-sound/liblc3: add 1.0.4 (diff)
downloadgentoo-fe77a8dc9b8f5c4b3f1194affdb7eb1246d06c4f.tar.gz
gentoo-fe77a8dc9b8f5c4b3f1194affdb7eb1246d06c4f.tar.bz2
gentoo-fe77a8dc9b8f5c4b3f1194affdb7eb1246d06c4f.zip
app-arch/createrepo_c: add 1.0.0
Signed-off-by: Arturo R Ochoa <arturo340@outlook.com> Closes: https://github.com/gentoo/gentoo/pull/32208 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch/createrepo_c')
-rw-r--r--app-arch/createrepo_c/Manifest1
-rw-r--r--app-arch/createrepo_c/createrepo_c-1.0.0.ebuild65
-rw-r--r--app-arch/createrepo_c/createrepo_c-9999.ebuild2
3 files changed, 67 insertions, 1 deletions
diff --git a/app-arch/createrepo_c/Manifest b/app-arch/createrepo_c/Manifest
index d139f5dcb5a4..ee5478fff10c 100644
--- a/app-arch/createrepo_c/Manifest
+++ b/app-arch/createrepo_c/Manifest
@@ -1 +1,2 @@
DIST createrepo_c-0.21.1.tar.gz 626012 BLAKE2B 87e7fff68bb06c9552ea80eada625e58130d171db48b0a1aa4965150b136e62c656e368e1bc7cc057e5fad105fff620bb37e171e367eb688725d2089e4181db4 SHA512 453b857ecde5aa63f57e4a783855e4f4c32a041b68c0bfbb5d5b06bc0010d6cd043ba374cb880cce1d0de160a37df2df2688e9886bf9c8d92c09fe530aa36dfe
+DIST createrepo_c-1.0.0.tar.gz 628628 BLAKE2B fed99e3eb7e2bb6dc9a045abb0c35c00bf4a733a1a70780109cda00b0db0bcf2ab96b466fcd4ce5b063642e900a6fb3d853870ea3af28da6c2b3af3655a49b2e SHA512 b412dd56c4e0b69467708a3646bf276b9c3a970b2f89f269b5c65a4efb961ed42769b9fca9d333588d2726e85fc80050a83a2e5b83e296f7e8b028ddd2bf9cf9
diff --git a/app-arch/createrepo_c/createrepo_c-1.0.0.ebuild b/app-arch/createrepo_c/createrepo_c-1.0.0.ebuild
new file mode 100644
index 000000000000..7433f2a6011f
--- /dev/null
+++ b/app-arch/createrepo_c/createrepo_c-1.0.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C implementation of createrepo"
+HOMEPAGE="https://github.com/rpm-software-management/createrepo_c"
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/rpm-software-management/createrepo_c.git"
+else
+ SRC_URI="https://github.com/rpm-software-management/createrepo_c/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="legacy test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ app-arch/bzip2:=
+ app-arch/drpm
+ app-arch/rpm
+ app-arch/xz-utils
+ app-arch/zchunk
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/openssl:=
+ net-misc/curl
+ sys-apps/file
+ sys-libs/libmodulemd
+ sys-libs/zlib:=
+"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DRPM=ON
+ # As best I can tell, this enables distribution as a wheel. No need for this on gentoo!
+ -DENABLE_PYTHON=OFF
+ # Upstream enables some 'Legacy' stuff by default, let's put that behind a USE flag
+ -DENABLE_LEGACY_WEAKDEPS=$(usex legacy ON OFF)
+ -DWITH_LEGACY_HASHES=$(usex legacy ON OFF)
+ -DWITH_LIBMODULEMD=ON
+ -DWITH_ZCHUNK=ON
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ # Tests have a magic target!
+ use test && cmake_src_compile tests
+}
+
+src_test() {
+ "${S}"_build/tests/run_tests.sh || die "Failed to run C library tests"
+}
diff --git a/app-arch/createrepo_c/createrepo_c-9999.ebuild b/app-arch/createrepo_c/createrepo_c-9999.ebuild
index da19ee9ac2f3..7433f2a6011f 100644
--- a/app-arch/createrepo_c/createrepo_c-9999.ebuild
+++ b/app-arch/createrepo_c/createrepo_c-9999.ebuild
@@ -12,7 +12,7 @@ if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://github.com/rpm-software-management/createrepo_c.git"
else
SRC_URI="https://github.com/rpm-software-management/createrepo_c/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-2"