summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/pbzip2/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/pbzip2/files')
-rw-r--r--app-arch/pbzip2/files/pbzip2-1.1.10-makefile.patch20
-rw-r--r--app-arch/pbzip2/files/pbzip2-1.1.6-makefile.patch62
-rw-r--r--app-arch/pbzip2/files/pbzip2-1.1.9-makefile.patch29
3 files changed, 111 insertions, 0 deletions
diff --git a/app-arch/pbzip2/files/pbzip2-1.1.10-makefile.patch b/app-arch/pbzip2/files/pbzip2-1.1.10-makefile.patch
new file mode 100644
index 000000000000..6524b6bf2a05
--- /dev/null
+++ b/app-arch/pbzip2/files/pbzip2-1.1.10-makefile.patch
@@ -0,0 +1,20 @@
+--- pbzip2-1.1.10/Makefile
++++ pbzip2-1.1.10/Makefile
+@@ -17,7 +17,7 @@
+
+
+ # Optimization flags
+-CXXFLAGS = -O2
++#CXXFLAGS = -O2
+
+ #CXXFLAGS += -g -Wall
+ #CXXFLAGS += -ansi
+@@ -50,7 +50,7 @@
+
+
+ # Linker flags
+-LDFLAGS =
++#LDFLAGS =
+
+
+ # External libraries
diff --git a/app-arch/pbzip2/files/pbzip2-1.1.6-makefile.patch b/app-arch/pbzip2/files/pbzip2-1.1.6-makefile.patch
new file mode 100644
index 000000000000..72b8795c0fde
--- /dev/null
+++ b/app-arch/pbzip2/files/pbzip2-1.1.6-makefile.patch
@@ -0,0 +1,62 @@
+--- Makefile.orig 2011-02-21 00:17:16.334746748 +0200
++++ Makefile 2011-02-21 00:19:16.504881112 +0200
+@@ -2,8 +2,6 @@
+ SHELL = /bin/sh
+
+ # Compiler to use
+-CC = g++
+-CFLAGS = -O2
+ #CFLAGS += -g -Wall
+ #CFLAGS += -ansi
+ #CFLAGS += -pedantic
+@@ -12,7 +10,7 @@
+ # Comment out CFLAGS line below for compatability mode for 32bit file sizes
+ # (less than 2GB) and systems that have compilers that treat int as 64bit
+ # natively (ie: modern AIX)
+-CFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
++CXXFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+
+ # Uncomment CFLAGS line below if you want to compile pbzip2 without load
+ # average support for systems that do not support it
+@@ -22,10 +20,10 @@
+ #CFLAGS += -DPBZIP_DEBUG
+
+ # Comment out CFLAGS line below to disable pthread semantics in code
+-CFLAGS += -D_POSIX_PTHREAD_SEMANTICS
++CXXFLAGS += -D_POSIX_PTHREAD_SEMANTICS
+
+ # Comment out CFLAGS line below to disable Thread stack size customization
+-CFLAGS += -DUSE_STACKSIZE_CUSTOMIZATION
++CXXFLAGS += -DUSE_STACKSIZE_CUSTOMIZATION
+
+ # Comment out CFLAGS line below to explicity set ignore trailing garbage
+ # default behavior: 0 - disabled; 1 - enabled (ignore garbage by default)
+@@ -34,11 +32,11 @@
+ #CFLAGS += -DIGNORE_TRAILING_GARBAGE=1
+
+ # On some compilers -pthreads
+-CFLAGS += -pthread
++CXXFLAGS += -pthread
+
+ # External libraries
+-LDFLAGS = -lbz2
+-LDFLAGS += -lpthread
++LIBS = -lbz2
++LIBS += -lpthread
+
+ # Where you want pbzip2 installed when you do 'make install'
+ PREFIX = /usr
+@@ -47,11 +45,11 @@
+
+ # Standard pbzip2 compile
+ pbzip2: pbzip2.cpp BZ2StreamScanner.cpp ErrorContext.cpp
+- $(CC) $(CFLAGS) $^ -o pbzip2 $(LDFLAGS)
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) $^ $(LIBS) -o pbzip2
+
+ # Choose this if you want to compile in a static version of the libbz2 library
+ pbzip2-static: pbzip2.cpp BZ2StreamScanner.cpp ErrorContext.cpp libbz2.a
+- $(CC) $(CFLAGS) $^ -o pbzip2 -I. -L. $(LDFLAGS)
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) $^ $(LIBS) -o pbzip2 -I. -L.
+
+ # Install the binary pbzip2 program and man page
+ install: pbzip2
diff --git a/app-arch/pbzip2/files/pbzip2-1.1.9-makefile.patch b/app-arch/pbzip2/files/pbzip2-1.1.9-makefile.patch
new file mode 100644
index 000000000000..39d35a3e0a2b
--- /dev/null
+++ b/app-arch/pbzip2/files/pbzip2-1.1.9-makefile.patch
@@ -0,0 +1,29 @@
+--- pbzip2-1.1.9/Makefile
++++ pbzip2-1.1.9/Makefile
+@@ -3,7 +3,7 @@
+
+
+ # Compiler to use
+-CXX = g++
++#CXX = g++
+
+
+ # Thread-related flags
+@@ -17,7 +17,7 @@
+
+
+ # Optimization flags
+-CXXFLAGS = -O2
++#CXXFLAGS = -O2
+
+ #CXXFLAGS += -g -Wall
+ #CXXFLAGS += -ansi
+@@ -50,7 +50,7 @@
+
+
+ # Linker flags
+-LDFLAGS =
++#LDFLAGS =
+
+
+ # External libraries