summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-06-30 13:01:47 +0200
committerMichał Górny <mgorny@gentoo.org>2017-06-30 13:19:13 +0200
commitff35101584a11d331625d6f69404008f510bbad1 (patch)
treea40d499290f83f457ce5e480b69ea59f6342969d /app-arch/pdlzip/pdlzip-1.8.ebuild
parentapp-arch/lzlib: Drop old (diff)
downloadgentoo-ff35101584a11d331625d6f69404008f510bbad1.tar.gz
gentoo-ff35101584a11d331625d6f69404008f510bbad1.tar.bz2
gentoo-ff35101584a11d331625d6f69404008f510bbad1.zip
app-arch/pdlzip: Bump to 1.8
Diffstat (limited to 'app-arch/pdlzip/pdlzip-1.8.ebuild')
-rw-r--r--app-arch/pdlzip/pdlzip-1.8.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-arch/pdlzip/pdlzip-1.8.ebuild b/app-arch/pdlzip/pdlzip-1.8.ebuild
new file mode 100644
index 000000000000..160eee1561e9
--- /dev/null
+++ b/app-arch/pdlzip/pdlzip-1.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Public-domain version of lzip compressor"
+HOMEPAGE="http://www.nongnu.org/lzip/pdlzip.html"
+SRC_URI="http://download.savannah.gnu.org/releases/lzip/pdlzip/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~x86-fbsd"
+IUSE=""
+
+src_configure() {
+ local myconf=(
+ --prefix="${EPREFIX}"/usr
+ CC="$(tc-getCC)"
+ CFLAGS="${CFLAGS}"
+ CPPFLAGS="${CPPFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ )
+
+ # not autotools-based
+ ./configure "${myconf[@]}" || die
+}