summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2018-01-19 20:26:02 +0100
committerFabian Groffen <grobian@gentoo.org>2018-01-19 20:26:18 +0100
commit00eb371909b41be58b3c951eab022754911adf96 (patch)
tree206ed2a062804c450a033016ac88d62860597ebe /app-arch/xar
parentsci-chemistry/gromacs: version bump (diff)
downloadgentoo-00eb371909b41be58b3c951eab022754911adf96.tar.gz
gentoo-00eb371909b41be58b3c951eab022754911adf96.tar.bz2
gentoo-00eb371909b41be58b3c951eab022754911adf96.zip
app-arch/xar: version bump to v1.8, bug #624642
Assign maintainership to Prefix team Bump to 1.8 version from Apple sources (xar-400) because this package is used by binutils-apple on macOS systems. Bug: https://bugs.gentoo.org/624642 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-arch/xar')
-rw-r--r--app-arch/xar/Manifest1
-rw-r--r--app-arch/xar/metadata.xml8
-rw-r--r--app-arch/xar/xar-1.8.ebuild46
3 files changed, 51 insertions, 4 deletions
diff --git a/app-arch/xar/Manifest b/app-arch/xar/Manifest
index e244c0e65b53..187e6e6db354 100644
--- a/app-arch/xar/Manifest
+++ b/app-arch/xar/Manifest
@@ -1,2 +1,3 @@
DIST xar-1.5.2.tar.gz 137973 BLAKE2B 1bd478134f9de23094cbf6b6c6d15100629ebb3359c39b39eb6a2bfad80fefc74282655ecd2c32ef0140f3d69f5a75c13665c0a5015dc3e278f99bab3c1a9ade SHA512 975861324ee31805eb107f51f2f6c43029b25601d4c1daa2dfee49ec7e25351e94798de9fb5c011b90d93dd6a3bbd3fe15c97ab0fc32f0b36b3000dd48cbf46b
DIST xar-1.6.1.tar.gz 180771 BLAKE2B efc15995941b7240486a02cad736981e4881dac8a576cb3188be1bb54aefbb612f374d82af56e1af27301d6d8f00698ad601f8ad4b0ae100107bbcd84cb203e8 SHA512 6ddf83130519006c4d8fe699cdf5a6e5e41b293f3411d4744bf3425fda21556ef54b95e46f60c13f9276070ccda94c8d95a543f1fda4cbd9e3087ab9b5d0b00b
+DIST xar-400.tar.gz 213319 BLAKE2B 55b8695313a1a5ae778b62791f716af00edba7e7b01500eac4b951e04cf7b18e84e0d508ac5471996796e5ab59e4628a4f85a63a5929b372555e28b222c77ab1 SHA512 c54850d5443c776f18d788bf7d026b3b08274ee71321d1615238c9fa2d20cc0b21f3f298364b0d0eecd98ce2a6efc8d5039cabd5a21c2419c430d90db004d159
diff --git a/app-arch/xar/metadata.xml b/app-arch/xar/metadata.xml
index 1e1e77a842ef..3ddd51ed75fb 100644
--- a/app-arch/xar/metadata.xml
+++ b/app-arch/xar/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="project">
+ <email>prefix@gentoo.org</email>
+ <name>Gentoo Prefix</name>
+ </maintainer>
<longdescription lang="en">
The XAR project aims to provide an easily extensible archive format.
Important design decisions include an easily extensible XML table of
@@ -13,7 +16,4 @@
compressed and uncompressed form, and the ability to query the table of
content's rich meta-data.
</longdescription>
- <upstream>
- <remote-id type="github">mackyle/xar</remote-id>
- </upstream>
</pkgmetadata>
diff --git a/app-arch/xar/xar-1.8.ebuild b/app-arch/xar/xar-1.8.ebuild
new file mode 100644
index 000000000000..d5fa86494a62
--- /dev/null
+++ b/app-arch/xar/xar-1.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic ltprune
+
+APPLE_PV=400
+DESCRIPTION="An easily extensible archive format"
+HOMEPAGE="https://opensource.apple.com/source/xar/"
+SRC_URI="https://opensource.apple.com/tarballs/xar/xar-${APPLE_PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="libressl kernel_Darwin"
+
+DEPEND="
+ !kernel_Darwin? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ app-arch/bzip2
+ sys-libs/zlib
+ dev-libs/libxml2
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.6.1-ext2.patch )
+
+S=${WORKDIR}/${PN}-${APPLE_PV}/${PN}
+
+src_prepare() {
+ default
+ sed -i -e 's/safe_dirname/xar_safe_dirname/' lib/linuxattr.c || die
+}
+
+src_configure() {
+ use kernel_Darwin || append-libs $(pkg-config --libs openssl)
+ econf \
+ --disable-static
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}