summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-24 23:42:28 +0100
committerSam James <sam@gentoo.org>2023-09-24 23:42:28 +0100
commit01b483bfd328f94bc0d718fdcf0ed8a56166fcb1 (patch)
tree362acd7465a895593e29fa5caeed6c2e541d02e6 /app-arch/zstd/files
parentsys-devel/gcc: drop 13.1.1_p20230527, 13.2.0, 13.2.1_p20230916 (diff)
downloadgentoo-01b483bfd328f94bc0d718fdcf0ed8a56166fcb1.tar.gz
gentoo-01b483bfd328f94bc0d718fdcf0ed8a56166fcb1.tar.bz2
gentoo-01b483bfd328f94bc0d718fdcf0ed8a56166fcb1.zip
app-arch/zstd: drop 1.4.9, 1.5.2-r3, 1.5.4-r2, 1.5.4-r3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch/zstd/files')
-rw-r--r--app-arch/zstd/files/zstd-1.5.4-crash-no-directory.patch115
-rw-r--r--app-arch/zstd/files/zstd-1.5.4-fix-no-zlib-build.patch61
-rw-r--r--app-arch/zstd/files/zstd-1.5.4-tests-no-programs.patch67
3 files changed, 0 insertions, 243 deletions
diff --git a/app-arch/zstd/files/zstd-1.5.4-crash-no-directory.patch b/app-arch/zstd/files/zstd-1.5.4-crash-no-directory.patch
deleted file mode 100644
index d64e1c1d34f0..000000000000
--- a/app-arch/zstd/files/zstd-1.5.4-crash-no-directory.patch
+++ /dev/null
@@ -1,115 +0,0 @@
-https://github.com/facebook/zstd/issues/3523
-https://github.com/facebook/zstd/pull/3541
-
-From 50e8f55e7d5928af9c3411afdb4fbedb4d8f770d Mon Sep 17 00:00:00 2001
-From: "W. Felix Handte" <w@felixhandte.com>
-Date: Thu, 9 Mar 2023 12:46:37 -0500
-Subject: [PATCH 1/3] Fix Python 3.6 Incompatibility in CLI Tests
-
---- a/tests/cli-tests/run.py
-+++ b/tests/cli-tests/run.py
-@@ -535,7 +535,8 @@ def _run_script(self, script: str, cwd: str) -> None:
- subprocess.run(
- args=[script],
- stdin=subprocess.DEVNULL,
-- capture_output=True,
-+ stdout=subprocess.PIPE,
-+ stderr=subprocess.PIPE,
- cwd=cwd,
- env=env,
- check=True,
-
-From c4c3e11958aed4dc99ec22e3d31c405217575a8c Mon Sep 17 00:00:00 2001
-From: "W. Felix Handte" <w@felixhandte.com>
-Date: Thu, 9 Mar 2023 12:47:40 -0500
-Subject: [PATCH 2/3] Avoid Calling `setvbuf()` on Null File Pointer
-
---- a/programs/fileio.c
-+++ b/programs/fileio.c
-@@ -644,18 +644,24 @@ FIO_openDstFile(FIO_ctx_t* fCtx, FIO_prefs_t* const prefs,
- #endif
- if (f == NULL) {
- DISPLAYLEVEL(1, "zstd: %s: %s\n", dstFileName, strerror(errno));
-+ } else {
-+ /* An increased buffer size can provide a significant performance
-+ * boost on some platforms. Note that providing a NULL buf with a
-+ * size that's not 0 is not defined in ANSI C, but is defined in an
-+ * extension. There are three possibilities here:
-+ * 1. Libc supports the extended version and everything is good.
-+ * 2. Libc ignores the size when buf is NULL, in which case
-+ * everything will continue as if we didn't call `setvbuf()`.
-+ * 3. We fail the call and execution continues but a warning
-+ * message might be shown.
-+ * In all cases due execution continues. For now, I believe that
-+ * this is a more cost-effective solution than managing the buffers
-+ * allocations ourselves (will require an API change).
-+ */
-+ if (setvbuf(f, NULL, _IOFBF, 1 MB)) {
-+ DISPLAYLEVEL(2, "Warning: setvbuf failed for %s\n", dstFileName);
-+ }
- }
-- /* An increased buffer size can provide a significant performance boost on some platforms.
-- * Note that providing a NULL buf with a size that's not 0 is not defined in ANSI C, but is defined
-- * in an extension. There are three possibilities here -
-- * 1. Libc supports the extended version and everything is good.
-- * 2. Libc ignores the size when buf is NULL, in which case everything will continue as if we didn't
-- * call `setvbuf`.
-- * 3. We fail the call and execution continues but a warning message might be shown.
-- * In all cases due execution continues. For now, I believe that this is a more cost-effective
-- * solution than managing the buffers allocations ourselves (will require an API change). */
-- if(setvbuf(f, NULL, _IOFBF, 1 MB))
-- DISPLAYLEVEL(2, "Warning: setvbuf failed for %s\n", dstFileName);
- return f;
- }
- }
-
-From 957a0ae52d0f49eccd260a22ceb5f5dfed064e9f Mon Sep 17 00:00:00 2001
-From: "W. Felix Handte" <w@felixhandte.com>
-Date: Thu, 9 Mar 2023 12:48:11 -0500
-Subject: [PATCH 3/3] Add CLI Test
-
---- /dev/null
-+++ b/tests/cli-tests/file-stat/compress-file-to-dir-without-write-perm.sh
-@@ -0,0 +1,12 @@
-+#!/bin/sh
-+
-+# motivated by issue #3523
-+
-+datagen > file
-+mkdir out
-+chmod 000 out
-+
-+zstd file -q --trace-file-stat -o out/file.zst
-+zstd -tq out/file.zst
-+
-+chmod 777 out
---- /dev/null
-+++ b/tests/cli-tests/file-stat/compress-file-to-dir-without-write-perm.sh.stderr.exact
-@@ -0,0 +1,26 @@
-+Trace:FileStat: > UTIL_isLink(file)
-+Trace:FileStat: < 0
-+Trace:FileStat: > UTIL_isConsole(2)
-+Trace:FileStat: < 0
-+Trace:FileStat: > UTIL_getFileSize(file)
-+Trace:FileStat: > UTIL_stat(-1, file)
-+Trace:FileStat: < 1
-+Trace:FileStat: < 65537
-+Trace:FileStat: > UTIL_stat(-1, file)
-+Trace:FileStat: < 1
-+Trace:FileStat: > UTIL_isDirectoryStat()
-+Trace:FileStat: < 0
-+Trace:FileStat: > UTIL_stat(-1, file)
-+Trace:FileStat: < 1
-+Trace:FileStat: > UTIL_isSameFile(file, out/file.zst)
-+Trace:FileStat: > UTIL_stat(-1, file)
-+Trace:FileStat: < 1
-+Trace:FileStat: > UTIL_stat(-1, out/file.zst)
-+Trace:FileStat: < 0
-+Trace:FileStat: < 0
-+Trace:FileStat: > UTIL_isRegularFile(out/file.zst)
-+Trace:FileStat: > UTIL_stat(-1, out/file.zst)
-+Trace:FileStat: < 0
-+Trace:FileStat: < 0
-+zstd: out/file.zst: Permission denied
-+zstd: can't stat out/file.zst : Permission denied -- ignored
-
diff --git a/app-arch/zstd/files/zstd-1.5.4-fix-no-zlib-build.patch b/app-arch/zstd/files/zstd-1.5.4-fix-no-zlib-build.patch
deleted file mode 100644
index c6e65cbe2b16..000000000000
--- a/app-arch/zstd/files/zstd-1.5.4-fix-no-zlib-build.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-https://bugs.gentoo.org/894058
-https://github.com/facebook/zstd/pull/3497
-
-From cc94fac7c879c47984bba7d60d5ce0c9834ff4c7 Mon Sep 17 00:00:00 2001
-From: "Alex Xu (Hello71)" <alex_y_xu@yahoo.ca>
-Date: Fri, 10 Feb 2023 19:30:30 -0500
-Subject: [PATCH] Use correct types in LZMA comp/decomp
-
-Bytef and uInt are zlib types, not available when zlib is disabled
-
-Fixes: 1598e6c634ac ("Async write for decompression")
-Fixes: cc0657f27d81 ("AsyncIO compression part 2 - added async read and asyncio to compression code (#3022)")
----
- programs/fileio.c | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/programs/fileio.c b/programs/fileio.c
-index 9a8300cdd8..d3ed9217d5 100644
---- a/programs/fileio.c
-+++ b/programs/fileio.c
-@@ -1173,8 +1173,8 @@ FIO_compressLzmaFrame(cRess_t* ress,
- }
-
- writeJob =AIO_WritePool_acquireJob(ress->writeCtx);
-- strm.next_out = (Bytef*)writeJob->buffer;
-- strm.avail_out = (uInt)writeJob->bufferSize;
-+ strm.next_out = (BYTE*)writeJob->buffer;
-+ strm.avail_out = writeJob->bufferSize;
- strm.next_in = 0;
- strm.avail_in = 0;
-
-@@ -1201,7 +1201,7 @@ FIO_compressLzmaFrame(cRess_t* ress,
- writeJob->usedBufferSize = compBytes;
- AIO_WritePool_enqueueAndReacquireWriteJob(&writeJob);
- outFileSize += compBytes;
-- strm.next_out = (Bytef*)writeJob->buffer;
-+ strm.next_out = (BYTE*)writeJob->buffer;
- strm.avail_out = writeJob->bufferSize;
- } }
- if (srcFileSize == UTIL_FILESIZE_UNKNOWN)
-@@ -2316,8 +2316,8 @@ FIO_decompressLzmaFrame(dRess_t* ress,
- }
-
- writeJob = AIO_WritePool_acquireJob(ress->writeCtx);
-- strm.next_out = (Bytef*)writeJob->buffer;
-- strm.avail_out = (uInt)writeJob->bufferSize;
-+ strm.next_out = (BYTE*)writeJob->buffer;
-+ strm.avail_out = writeJob->bufferSize;
- strm.next_in = (BYTE const*)ress->readCtx->srcBuffer;
- strm.avail_in = ress->readCtx->srcBufferLoaded;
-
-@@ -2345,7 +2345,7 @@ FIO_decompressLzmaFrame(dRess_t* ress,
- writeJob->usedBufferSize = decompBytes;
- AIO_WritePool_enqueueAndReacquireWriteJob(&writeJob);
- outFileSize += decompBytes;
-- strm.next_out = (Bytef*)writeJob->buffer;
-+ strm.next_out = (BYTE*)writeJob->buffer;
- strm.avail_out = writeJob->bufferSize;
- } }
- if (ret == LZMA_STREAM_END) break;
-
diff --git a/app-arch/zstd/files/zstd-1.5.4-tests-no-programs.patch b/app-arch/zstd/files/zstd-1.5.4-tests-no-programs.patch
deleted file mode 100644
index ec1fc325920f..000000000000
--- a/app-arch/zstd/files/zstd-1.5.4-tests-no-programs.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-https://github.com/facebook/zstd/pull/3490
-
-From 183a18a45c1d69f8c42b9fcd25e6d28f9b3d75bb Mon Sep 17 00:00:00 2001
-From: Eli Schwartz <eschwartz@archlinux.org>
-Date: Fri, 10 Feb 2023 00:28:47 -0500
-Subject: [PATCH 1/2] meson: correctly specify the dependency relationship for
- playtests
-
-It depends on the zstd program being built, and passes it as an env
-variable. Just like datagen. But for datagen, we explicitly depend on
-it, while for zstd, we assume it's built as part of "all".
-
-This can be wrong in two cases:
-- when running individual tests, meson can (re)build just what is needed
- for that one test
-- a later patch will handle building zstd but not by default
---- a/tests/meson.build
-+++ b/tests/meson.build
-@@ -162,7 +162,7 @@ if host_machine_os != os_windows
- playTests_sh,
- args: opt,
- env: ['ZSTD_BIN=' + zstd.full_path(), 'DATAGEN_BIN=./datagen'],
-- depends: [datagen],
-+ depends: [datagen, zstd],
- suite: suite,
- workdir: meson.current_build_dir(),
- timeout: 2800) # Timeout should work on HDD drive
-
-From 97ab0e2ab60fdda78f610032408df104de20b9f1 Mon Sep 17 00:00:00 2001
-From: Eli Schwartz <eschwartz@archlinux.org>
-Date: Thu, 9 Feb 2023 23:55:09 -0500
-Subject: [PATCH 2/2] meson: always build the zstd binary when tests are
- enabled
-
-We need to run it for the tests, even if programs are disabled. So if
-they are disabled, create a build rule for the program, but don't
-install it. Just make it available for the test itself.
---- a/meson.build
-+++ b/meson.build
-@@ -132,7 +132,7 @@ endif
-
- subdir('lib')
-
--if bin_programs
-+if bin_programs or bin_tests
- subdir('programs')
- endif
-
---- a/programs/meson.build
-+++ b/programs/meson.build
-@@ -72,7 +72,14 @@ zstd = executable('zstd',
- c_args: zstd_c_args,
- dependencies: zstd_deps,
- export_dynamic: export_dynamic_on_windows, # Since Meson 0.45.0
-- install: true)
-+ build_by_default: bin_programs,
-+ install: bin_programs)
-+
-+if not bin_programs
-+ # we generate rules to build the programs, but don't install anything
-+ # so do not continue to installing scripts and manpages
-+ subdir_done()
-+endif
-
- zstd_frugal_sources = [join_paths(zstd_rootdir, 'programs/zstdcli.c'),
- join_paths(zstd_rootdir, 'programs/timefn.c'),
-