summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-15 07:01:36 +0100
committerSam James <sam@gentoo.org>2023-04-15 07:01:36 +0100
commit339d6c1ccc9a459876d635458a8fbc1b829fb51c (patch)
tree09b010f8eab203842da808b0a2f7e5dff7db8d9c /app-arch
parentmedia-video/mediainfo: add 23.03 (diff)
downloadgentoo-339d6c1ccc9a459876d635458a8fbc1b829fb51c.tar.gz
gentoo-339d6c1ccc9a459876d635458a8fbc1b829fb51c.tar.bz2
gentoo-339d6c1ccc9a459876d635458a8fbc1b829fb51c.zip
app-arch/engrampa: fix build w/ clang 16
Closes: https://bugs.gentoo.org/875404 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/engrampa/engrampa-1.26.0-r1.ebuild (renamed from app-arch/engrampa/engrampa-1.26.0.ebuild)6
-rw-r--r--app-arch/engrampa/files/engrampa-1.26.0-clang16.patch24
2 files changed, 29 insertions, 1 deletions
diff --git a/app-arch/engrampa/engrampa-1.26.0.ebuild b/app-arch/engrampa/engrampa-1.26.0-r1.ebuild
index 82d52bffe28c..3d8bd7013852 100644
--- a/app-arch/engrampa/engrampa-1.26.0.ebuild
+++ b/app-arch/engrampa/engrampa-1.26.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -42,6 +42,10 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.26.0-clang16.patch
+)
+
src_configure() {
mate_src_configure \
--disable-run-in-place \
diff --git a/app-arch/engrampa/files/engrampa-1.26.0-clang16.patch b/app-arch/engrampa/files/engrampa-1.26.0-clang16.patch
new file mode 100644
index 000000000000..334987a40baf
--- /dev/null
+++ b/app-arch/engrampa/files/engrampa-1.26.0-clang16.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/875404
+https://github.com/mate-desktop/engrampa/pull/477
+
+From f54425f1f994fc235c6cdd4013eb9fcf17da9f29 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Fri, 14 Apr 2023 22:35:08 +0200
+Subject: [PATCH] file-utils: Include <strings.h> for strcasecmp
+
+The _XOPEN_SOURCE macro definition overrides _DEFAULT_SOURCE
+and disables the declaration in <string.h>.
+
+This avoids an implicit function declaration and build failures
+with future compilers.
+--- a/src/file-utils.c
++++ b/src/file-utils.c
+@@ -27,6 +27,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <strings.h>
+ #include <ctype.h>
+ #include <time.h>
+ #include <unistd.h>
+