summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-01-27 14:59:29 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-01-29 00:02:22 +0100
commitb6c6271f86c8224689be789f9cd0fb566505195f (patch)
treeacb566490d9cc6dab7b087c4822b1ebcf95f3dae /app-benchmarks/geekbench/geekbench-4.3.3.ebuild
parentgames-fps/eduke32: drop old version. (diff)
downloadgentoo-b6c6271f86c8224689be789f9cd0fb566505195f.tar.gz
gentoo-b6c6271f86c8224689be789f9cd0fb566505195f.tar.bz2
gentoo-b6c6271f86c8224689be789f9cd0fb566505195f.zip
app-benchmarks/geekbench: bump to version 4.3.3.
Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/10914 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-benchmarks/geekbench/geekbench-4.3.3.ebuild')
-rw-r--r--app-benchmarks/geekbench/geekbench-4.3.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-benchmarks/geekbench/geekbench-4.3.3.ebuild b/app-benchmarks/geekbench/geekbench-4.3.3.ebuild
new file mode 100644
index 000000000000..e9e4197b56ba
--- /dev/null
+++ b/app-benchmarks/geekbench/geekbench-4.3.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A Cross-Platform Benchmark for Android, iOS, Linux, MacOS and Windows"
+HOMEPAGE="https://www.geekbench.com"
+SRC_URI="https://cdn.geekbench.com/Geekbench-${PV}-Linux.tar.gz"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="geekbench"
+SLOT="4"
+
+RESTRICT="bindist fetch mirror strip"
+
+S="${WORKDIR}/Geekbench-${PV}-Linux"
+
+QA_PREBUILT="
+ opt/geekbench4/geekbench4
+ opt/geekbench4/geekbench_x86_32
+ opt/geekbench4/geekbench_x86_64
+"
+
+pkg_nofetch() {
+ elog "Please download ${A} from ${HOMEPAGE}/download/linux"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_install() {
+ exeinto "/opt/geekbench4"
+ doexe "geekbench4" "geekbench_x86_32" "geekbench_x86_64"
+
+ insinto "/opt/geekbench4"
+ doins "geekbench.plar"
+
+ dodir "/opt/bin"
+ dosym "../geekbench4/geekbench4" "/opt/bin/geekbench4"
+}
+
+pkg_postinst() {
+ elog "If you have purchased a commercial license, you can enter"
+ elog "your email address and your license key with the following command:"
+ elog "geekbench4 -r <email address> <license key>"
+}