summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-cdr/mode2cdmaker/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-cdr/mode2cdmaker/files')
-rw-r--r--app-cdr/mode2cdmaker/files/mode2cdmaker-1.5.1-gentoo.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-cdr/mode2cdmaker/files/mode2cdmaker-1.5.1-gentoo.patch b/app-cdr/mode2cdmaker/files/mode2cdmaker-1.5.1-gentoo.patch
new file mode 100644
index 000000000000..502819c11df3
--- /dev/null
+++ b/app-cdr/mode2cdmaker/files/mode2cdmaker-1.5.1-gentoo.patch
@@ -0,0 +1,46 @@
+diff -ur mode2cdmaker-1.5.1.orig/Makefile.linux mode2cdmaker-1.5.1/Makefile.linux
+--- mode2cdmaker-1.5.1.orig/Makefile.linux 2003-02-01 16:27:18.000000000 +0200
++++ mode2cdmaker-1.5.1/Makefile.linux 2008-06-15 19:24:14.000000000 +0300
+@@ -4,8 +4,8 @@
+ output=mode2cdmaker
+
+ all:
+- gcc -c $(srcs)
+- gcc -o $(output) $(objs)
++ $(CC) ${CFLAGS} -DMAX_PATH=512 -c $(srcs)
++ $(CC) ${LDFLAGS} -o $(output) $(objs)
+
+ clean:
+ -rm -f $(objs) $(output)
+diff -ur mode2cdmaker-1.5.1.orig/mkvcdfs.c mode2cdmaker-1.5.1/mkvcdfs.c
+--- mode2cdmaker-1.5.1.orig/mkvcdfs.c 2003-03-14 19:57:38.000000000 +0200
++++ mode2cdmaker-1.5.1/mkvcdfs.c 2008-06-15 19:23:25.000000000 +0300
+@@ -120,6 +120,7 @@
+ #endif
+ #endif
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <fcntl.h>
+ #include <string.h>
+ #include <ctype.h>
+@@ -629,7 +630,7 @@
+ next_command[1]=(char*)malloc(256);
+ while (fgets(next_command[1],256,pf))
+ {
+- next_command[1][lstrlen(next_command[1])-1]=0;
++ next_command[1][strlen(next_command[1])-1]=0;
+ parse_params(2,next_command,idepth+1);
+ }
+ fclose(pf);
+diff -ur mode2cdmaker-1.5.1.orig/vcdisofs.c mode2cdmaker-1.5.1/vcdisofs.c
+--- mode2cdmaker-1.5.1.orig/vcdisofs.c 2003-02-02 00:02:44.000000000 +0200
++++ mode2cdmaker-1.5.1/vcdisofs.c 2008-06-15 19:19:59.000000000 +0300
+@@ -80,6 +80,8 @@
+ #include <windows.h>
+ #endif
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <time.h>
+ #include "defaults.h"
+