summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <me@rahil.rocks>2024-06-12 22:41:48 +0530
committerZac Medico <zmedico@gentoo.org>2024-06-13 12:10:46 -0700
commit73c4de08800950341a83df38134b1405278fbf21 (patch)
treece1c48bc670cd3d7c8a72193ada35582b2b197fe /app-containers
parentapp-containers/containers-common: update to 0.59.1 (diff)
downloadgentoo-73c4de08800950341a83df38134b1405278fbf21.tar.gz
gentoo-73c4de08800950341a83df38134b1405278fbf21.tar.bz2
gentoo-73c4de08800950341a83df38134b1405278fbf21.zip
app-containers/containers-common: cleanup
Signed-off-by: Rahil Bhimjiani <me@rahil.rocks> Closes: https://github.com/gentoo/gentoo/pull/37135 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/containers-common/Manifest1
-rw-r--r--app-containers/containers-common/containers-common-0.57.0.ebuild68
-rw-r--r--app-containers/containers-common/containers-common-0.57.3.ebuild59
-rw-r--r--app-containers/containers-common/containers-common-0.58.0.ebuild60
4 files changed, 0 insertions, 188 deletions
diff --git a/app-containers/containers-common/Manifest b/app-containers/containers-common/Manifest
index 1ef18a9a70a8..09300934cd25 100644
--- a/app-containers/containers-common/Manifest
+++ b/app-containers/containers-common/Manifest
@@ -1,4 +1,3 @@
DIST containers-common-0.57.0.tar.gz 12700958 BLAKE2B 8432a7d839b94b59eabd75d4978a4d0c1340a64ed626db74e74a8318e08c61172bfba5e4f4c4b0dfffec302c5a310bb5be8fad3ab4d91a6d89ced373a0a6f297 SHA512 b993821040788085ff44e48023a64cea4e3e7e50731c359087bd287168e6849a543d930acbdaff2437fc7951acc46f7183f337dd977215eca814332e6869d1e3
-DIST containers-common-0.57.3.tar.gz 12702863 BLAKE2B 7842893f9b8ca72fa0657ea716f61cad95c4a8bff680922a15cffad4cecf897683591272fee83494e800023a432458cc689a810726e60e4d5ff9dd6af2d71737 SHA512 f0b7c4632317e666342f7b31bd9e5e9cdc794125d4d358e6a62ba115099ee1e6b33751cff982dcadbb3055b093d05fbd1049402f79ca2e6465cc6fcabce7c928
DIST containers-common-0.58.0.tar.gz 13164567 BLAKE2B 17795eec2d38b4d8b9d6afeb20e249208c5ae2ac767a365ef7313d1e7c36eadb9a9eb284a657dfe3f4fcb0577448d4883fabbad76e0318425fdc03809e27cd7c SHA512 6f569d68d3b0e5ead304c7f23341808d66a47b6352c772d353d50c5f4777cd8a5a5b85d6faaf2887f828c17ec49b9c5f929177a67294b5bbb69baa80656982a8
DIST containers-common-0.59.1.tar.gz 13131960 BLAKE2B 5b3b947789f889955716816fa15a84eb2f398d6cfb59c85bd969442fb8f55715f2c17c78d963ae913d96e6a109f69da745cfc7db8d23e2ed6516f992b982dda0 SHA512 452c9b84f7631afdf39b7b1fcaf2f721bede312d8fb55b89a953f16ca3546c0df11bb23c99588a592b6375275516d1364570261fbc15301ca3ad486ee66eae32
diff --git a/app-containers/containers-common/containers-common-0.57.0.ebuild b/app-containers/containers-common/containers-common-0.57.0.ebuild
deleted file mode 100644
index 2d56b46669f2..000000000000
--- a/app-containers/containers-common/containers-common-0.57.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="Common config files and docs for Containers stack"
-HOMEPAGE="https://github.com/containers/common"
-
-if [[ ${PV} == 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/containers/common.git"
-else
- SRC_URI="https://github.com/containers/common/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${P#containers-}"
- KEYWORDS="amd64 ~arm64 ~riscv"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-RESTRICT="test"
-RDEPEND="
- <app-containers/containers-image-5.29.2
- app-containers/containers-storage
- app-containers/containers-shortnames
- !<app-containers/podman-4.5.0-r1
- net-firewall/nftables
- net-firewall/iptables[nftables]
- || ( app-containers/crun app-containers/runc )
- || (
- ( >=app-containers/netavark-1.6.0 >=app-containers/aardvark-dns-1.6.0 )
- >=app-containers/cni-plugins-0.9.1
- )
-"
-
-BDEPEND="
- >=dev-go/go-md2man-2.0.2
-"
-
-src_prepare() {
- default
-
- [[ -f docs/Makefile && -f Makefile ]] || die
- sed -i -e 's|/usr/local|/usr|g;' docs/Makefile Makefile || die
-
- # add comments to mounts.conf
- eapply "${FILESDIR}/examplify-mounts-conf.patch"
-}
-
-src_compile() {
- emake docs
-}
-
-src_install() {
- emake DESTDIR="${ED}" install
-
- insinto /etc/containers
- # https://github.com/containers/skopeo/raw/main/default-policy.json
- doins pkg/config/containers.conf "${FILESDIR}/policy.json"
-
- insinto /etc/containers/registries.d
- # https://github.com/containers/skopeo/raw/main/default.yaml
- doins "${FILESDIR}/default.yaml"
-
- insinto /usr/share/containers
- doins pkg/seccomp/seccomp.json pkg/subscriptions/mounts.conf
-
- keepdir /etc/containers/certs.d /etc/containers/oci/hooks.d /etc/containers/systemd /var/lib/containers/sigstore
-}
diff --git a/app-containers/containers-common/containers-common-0.57.3.ebuild b/app-containers/containers-common/containers-common-0.57.3.ebuild
deleted file mode 100644
index 5a0aa2f26d0b..000000000000
--- a/app-containers/containers-common/containers-common-0.57.3.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="Common config files and docs for Containers stack"
-HOMEPAGE="https://github.com/containers/common"
-
-if [[ ${PV} == 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/containers/common.git"
-else
- SRC_URI="https://github.com/containers/common/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${P#containers-}"
- KEYWORDS="~amd64 ~arm64 ~riscv"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-RESTRICT="test"
-RDEPEND="
- app-containers/containers-image
- app-containers/containers-storage
- app-containers/containers-shortnames
- net-firewall/nftables
- net-firewall/iptables[nftables]
- || ( app-containers/crun app-containers/runc )
- || (
- ( >=app-containers/netavark-1.6.0 >=app-containers/aardvark-dns-1.6.0 )
- >=app-containers/cni-plugins-0.9.1
- )
-"
-
-BDEPEND="
- >=dev-go/go-md2man-2.0.3
-"
-
-src_prepare() {
- default
-
- [[ -f docs/Makefile && -f Makefile ]] || die
- sed -i -e 's|/usr/local|/usr|g;' docs/Makefile Makefile || die
-
- # add comments to mounts.conf
- eapply "${FILESDIR}/examplify-mounts-conf.patch"
-}
-
-src_compile() {
- emake docs
-}
-
-src_install() {
- emake DESTDIR="${ED}" install
-
- insinto /usr/share/containers
- doins pkg/seccomp/seccomp.json pkg/subscriptions/mounts.conf
-
- keepdir /etc/containers/certs.d /etc/containers/oci/hooks.d /etc/containers/systemd /var/lib/containers/sigstore
-}
diff --git a/app-containers/containers-common/containers-common-0.58.0.ebuild b/app-containers/containers-common/containers-common-0.58.0.ebuild
deleted file mode 100644
index c4d53773f1d9..000000000000
--- a/app-containers/containers-common/containers-common-0.58.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="Common config files and docs for Containers stack"
-HOMEPAGE="https://github.com/containers/common"
-
-if [[ ${PV} == 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/containers/common.git"
-else
- SRC_URI="https://github.com/containers/common/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${P#containers-}"
- KEYWORDS="~amd64 ~arm64 ~riscv"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-RESTRICT="test"
-RDEPEND="
- app-containers/containers-image
- app-containers/containers-storage
- app-containers/containers-shortnames
- net-firewall/nftables
- net-firewall/iptables[nftables]
- || ( app-containers/crun app-containers/runc )
- || (
- ( >=app-containers/netavark-1.6.0 >=app-containers/aardvark-dns-1.6.0 )
- >=app-containers/cni-plugins-0.9.1
- )
-"
-
-BDEPEND="
- >=dev-go/go-md2man-2.0.3
-"
-
-PATCHES=(
- "${FILESDIR}/examplify-mounts-conf.patch"
-)
-
-src_prepare() {
- default
-
- [[ -f docs/Makefile && -f Makefile ]] || die
- sed -i -e 's|/usr/local|/usr|g;' docs/Makefile Makefile || die
-}
-
-src_compile() {
- emake docs
-}
-
-src_install() {
- emake DESTDIR="${ED}" install
-
- insinto /usr/share/containers
- doins pkg/seccomp/seccomp.json pkg/subscriptions/mounts.conf
-
- keepdir /etc/containers/certs.d /etc/containers/oci/hooks.d /etc/containers/systemd /var/lib/containers/sigstore
-}