summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-08 00:41:36 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-08 01:29:43 +0100
commit7f59241554f83a3ccbdbe3bc3fbcc816d53ab73d (patch)
treebe63c677f9ddc6936b4239f817b7cfeb860000ed /app-containers
parentapp-containers/devcontainer: drop old 0.52.1 (diff)
downloadgentoo-7f59241554f83a3ccbdbe3bc3fbcc816d53ab73d.tar.gz
gentoo-7f59241554f83a3ccbdbe3bc3fbcc816d53ab73d.tar.bz2
gentoo-7f59241554f83a3ccbdbe3bc3fbcc816d53ab73d.zip
app-containers/devcontainer: bump to 0.54.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/devcontainer/Manifest1
-rw-r--r--app-containers/devcontainer/devcontainer-0.54.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-containers/devcontainer/Manifest b/app-containers/devcontainer/Manifest
index fca7961fa6f5..31bb198f2151 100644
--- a/app-containers/devcontainer/Manifest
+++ b/app-containers/devcontainer/Manifest
@@ -1,2 +1,3 @@
DIST devcontainer-0.53.0.tgz 614575 BLAKE2B b7279b629cae49da39eca9defa17055b94c95db8ed79f78ec869f15a361ae12b4142817433e789c0d1231a753a1c7cc0247d5de738981f0f17c61de82aa7a8c9 SHA512 942e3b4b4ab19de876f22fcad16a1b41e5edc271cafcbc3281f198a80156e44ea94217cfcb4e0ef63ca96e6e854e030f4f70a51e7bcc655f0cb8cf23dcf003dc
DIST devcontainer-0.54.1.tgz 603740 BLAKE2B ea3dddfa4788efa704d73fae109b7c844d64c01a3be50a94be847a037af2a8878caca546a3b99bf0e54faabca27309f75c11b480a7b7d51c8b6f3438a55f3e65 SHA512 0eb8da1b74f23c30da8ff01244760cfb0dab857a8397b4995bb8228393624e376c9a7631aa1fe87164464221b8592c6397aa687032d4f8c1fd9e6225a8b394f6
+DIST devcontainer-0.54.2.tgz 603920 BLAKE2B 85737eccc793da9454fb2e8069f843356781606ce8fbfeedf1f04bf1d012f5f1ec70b1e6fd200fc2d43fa28f3b8a9647e05f42a42096dbaf6cab95a410cb6df9 SHA512 4d5e0f8be0dd3ff9b755037e489f86aeab40bc1b1ba3a558e9be5ae89ab7f109874ca04082e6851d3fe1fca2fd4f8d8c09df8e6bed273de2719e5784f30ca71c
diff --git a/app-containers/devcontainer/devcontainer-0.54.2.ebuild b/app-containers/devcontainer/devcontainer-0.54.2.ebuild
new file mode 100644
index 000000000000..399665b46cde
--- /dev/null
+++ b/app-containers/devcontainer/devcontainer-0.54.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Reference implementation of the Development Containers specification"
+HOMEPAGE="https://containers.dev/
+ https://github.com/devcontainers/cli/"
+SRC_URI="https://registry.npmjs.org/@devcontainers/cli/-/cli-${PV}.tgz
+ -> ${P}.tgz"
+S="${WORKDIR}/package"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ net-libs/nodejs
+"
+BDEPEND="
+ >=net-libs/nodejs-16[npm]
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local -a my_npm_opts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}/usr"
+ --progress false
+ --verbose
+ )
+ npm "${my_npm_opts[@]}" install "${DISTDIR}/${P}.tgz" || die "npm install failed"
+
+ einstalldocs
+}