summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-01-06 18:22:08 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-01-06 18:24:21 -0600
commitabb41e5936b56699f158f94d1d5aabbdd3964128 (patch)
treeef92dffc552570494554a85392fbd2e1ba9fb6f2 /app-crypt/certbot-apache/certbot-apache-0.39.0.ebuild
parentapp-crypt/certbot: 1.0.0-r1 stable amd64/x86 with cleanup (diff)
downloadgentoo-abb41e5936b56699f158f94d1d5aabbdd3964128.tar.gz
gentoo-abb41e5936b56699f158f94d1d5aabbdd3964128.tar.bz2
gentoo-abb41e5936b56699f158f94d1d5aabbdd3964128.zip
app-crypt/certbot-apache: 1.0.0 stable amd64 / x86 with cleanup
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt/certbot-apache/certbot-apache-0.39.0.ebuild')
-rw-r--r--app-crypt/certbot-apache/certbot-apache-0.39.0.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/app-crypt/certbot-apache/certbot-apache-0.39.0.ebuild b/app-crypt/certbot-apache/certbot-apache-0.39.0.ebuild
deleted file mode 100644
index c926083fd0ac..000000000000
--- a/app-crypt/certbot-apache/certbot-apache-0.39.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=(python{2_7,3_6,3_7})
-
-if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="https://github.com/certbot/certbot.git"
- inherit git-r3
- S=${WORKDIR}/${P}/${PN}
-else
- SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
- KEYWORDS="amd64 ~arm64 x86"
- S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
-fi
-
-inherit distutils-r1
-
-DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
-HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
- >=app-crypt/certbot-0.39.0[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/python-augeas[${PYTHON_USEDEP}]
- dev-python/zope-component[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
- nosetests || die
-}