summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-11-06 13:14:57 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-11-06 13:49:32 -0600
commitd4e3ece1a7f3a4f7c5bfcefe66ed6ab9ce2d6522 (patch)
tree384e5fc522d02a4130bad733282620fee1cdb68e /app-crypt/certbot-apache/certbot-apache-0.40.1.ebuild
parentapp-crypt/certbot: 0.40.1 bump (diff)
downloadgentoo-d4e3ece1a7f3a4f7c5bfcefe66ed6ab9ce2d6522.tar.gz
gentoo-d4e3ece1a7f3a4f7c5bfcefe66ed6ab9ce2d6522.tar.bz2
gentoo-d4e3ece1a7f3a4f7c5bfcefe66ed6ab9ce2d6522.zip
app-crypt/certbot-apache: 0.40.1 bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt/certbot-apache/certbot-apache-0.40.1.ebuild')
-rw-r--r--app-crypt/certbot-apache/certbot-apache-0.40.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/certbot-apache-0.40.1.ebuild b/app-crypt/certbot-apache/certbot-apache-0.40.1.ebuild
new file mode 100644
index 000000000000..a90d0aa26db2
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-0.40.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-0.39.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests || die
+}