summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-04-19 13:30:46 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-04-19 13:31:05 -0500
commit58a4db8536f7b5ae401fba9db91a9f8401e043ed (patch)
treecbe1107acc3dbae85a196f9022e7247ddf54773a /app-crypt/certbot-apache/certbot-apache-1.3.0-r1.ebuild
parentdev-python/python-augeas: 1.1.0 bump (diff)
downloadgentoo-58a4db8536f7b5ae401fba9db91a9f8401e043ed.tar.gz
gentoo-58a4db8536f7b5ae401fba9db91a9f8401e043ed.tar.bz2
gentoo-58a4db8536f7b5ae401fba9db91a9f8401e043ed.zip
app-crypt/certbot-apache: fix tests (use pytest instead of nose)
pytest is what upstream uses, so use it here too Closes: https://bugs.gentoo.org/718130 Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --force Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt/certbot-apache/certbot-apache-1.3.0-r1.ebuild')
-rw-r--r--app-crypt/certbot-apache/certbot-apache-1.3.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/certbot-apache-1.3.0-r1.ebuild b/app-crypt/certbot-apache/certbot-apache-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..3ef09260e724
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-1.3.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_6,3_7})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+ KEYWORDS="amd64 ~arm64 x86"
+ S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test || die
+}