summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-25 03:08:50 +0100
committerSam James <sam@gentoo.org>2021-06-25 20:31:50 +0100
commitf7e2367203f61eb544373ea641a70b68aea579a0 (patch)
tree195def891508257ffb08674ff69a6867aaf96827 /app-crypt/johntheripper-jumbo
parentwww-servers/nginx: add virtual/libcrypt dependency (diff)
downloadgentoo-f7e2367203f61eb544373ea641a70b68aea579a0.tar.gz
gentoo-f7e2367203f61eb544373ea641a70b68aea579a0.tar.bz2
gentoo-f7e2367203f61eb544373ea641a70b68aea579a0.zip
app-crypt/johntheripper-jumbo: add virtual/libcrypt dependency, fix gcc 11
Needed for upcoming libxcrypt migration. Closes: https://bugs.gentoo.org/786651 Acked-by: David Seifert <soap@gentoo.org> Reported-by: John Helmert III <ajak@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt/johntheripper-jumbo')
-rw-r--r--app-crypt/johntheripper-jumbo/files/johntheripper-jumbo-1.9.0-gcc11.patch53
-rw-r--r--app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0-r3.ebuild (renamed from app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0-r2.ebuild)10
-rw-r--r--app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild5
3 files changed, 63 insertions, 5 deletions
diff --git a/app-crypt/johntheripper-jumbo/files/johntheripper-jumbo-1.9.0-gcc11.patch b/app-crypt/johntheripper-jumbo/files/johntheripper-jumbo-1.9.0-gcc11.patch
new file mode 100644
index 000000000000..2901c5bc4bd6
--- /dev/null
+++ b/app-crypt/johntheripper-jumbo/files/johntheripper-jumbo-1.9.0-gcc11.patch
@@ -0,0 +1,53 @@
+https://bugs.gentoo.org/786651
+https://github.com/openwall/john/commit/8152ac071bce1ebc98fac6bed962e90e9b92d8cf.patch
+
+From 8152ac071bce1ebc98fac6bed962e90e9b92d8cf Mon Sep 17 00:00:00 2001
+From: Ferry Huberts <ferry.huberts@pelagic.nl>
+Date: Tue, 9 Mar 2021 22:04:46 +0100
+Subject: [PATCH] Fix alignment compile errors on GCC 11
+
+Signed-off-by: Ferry Huberts <ferry.huberts@pelagic.nl>
+---
+ src/blake2.h | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/blake2.h b/src/blake2.h
+index b05208117e..b4398f9e13 100644
+--- a/src/blake2.h
++++ b/src/blake2.h
+@@ -57,7 +57,7 @@ extern "C" {
+ uint8_t personal[BLAKE2S_PERSONALBYTES]; // 32
+ } blake2s_param;
+
+- JTR_ALIGN( 64 ) typedef struct __blake2s_state
++ typedef struct JTR_ALIGN( 64 ) __blake2s_state
+ {
+ uint32_t h[8];
+ uint32_t t[2];
+@@ -82,7 +82,7 @@ extern "C" {
+ uint8_t personal[BLAKE2B_PERSONALBYTES]; // 64
+ } blake2b_param;
+
+- JTR_ALIGN( 64 ) typedef struct __blake2b_state
++ typedef struct JTR_ALIGN( 64 ) __blake2b_state
+ {
+ uint64_t h[8];
+ uint64_t t[2];
+@@ -94,7 +94,7 @@ extern "C" {
+ #if defined(JOHN_NO_SIMD) || (!defined(__SSE2__) && !defined(__SSE4_1__) && !defined(__XOP__))
+ typedef struct __blake2sp_state
+ #else
+- JTR_ALIGN( 64 ) typedef struct __blake2sp_state
++ typedef struct JTR_ALIGN( 64 ) __blake2sp_state
+ #endif
+ {
+ blake2s_state S[8][1];
+@@ -106,7 +106,7 @@ extern "C" {
+ #if defined(JOHN_NO_SIMD) || (!defined(__SSE2__) && !defined(__SSE4_1__) && !defined(__XOP__))
+ typedef struct __blake2bp_state
+ #else
+- JTR_ALIGN( 64 ) typedef struct __blake2bp_state
++ typedef struct JTR_ALIGN( 64 ) __blake2bp_state
+ #endif
+ {
+ blake2b_state S[4][1];
diff --git a/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0-r2.ebuild b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0-r3.ebuild
index 12b9fbef4708..632f59d7a16f 100644
--- a/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0-r2.ebuild
+++ b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0-r3.ebuild
@@ -5,7 +5,7 @@ EAPI=7
inherit flag-o-matic toolchain-funcs pax-utils
-DESCRIPTION="fast password cracker"
+DESCRIPTION="Fast password cracker"
HOMEPAGE="http://www.openwall.com/john/"
MY_PN="JohnTheRipper"
@@ -28,18 +28,22 @@ SLOT="0"
IUSE="custom-cflags kerberos mpi opencl openmp pcap"
DEPEND=">=dev-libs/openssl-1.0.1:0=
+ virtual/libcrypt:=
mpi? ( virtual/mpi )
opencl? ( virtual/opencl )
kerberos? ( virtual/krb5 )
pcap? ( net-libs/libpcap )
- dev-libs/gmp:*
+ dev-libs/gmp:=
sys-libs/zlib
app-arch/bzip2"
RDEPEND="${DEPEND}
!app-crypt/johntheripper"
-PATCHES=( "${FILESDIR}/${P}-opencl-fix.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-opencl-fix.patch"
+ "${FILESDIR}/${P}-gcc11.patch"
+)
pkg_setup() {
if use openmp && [[ ${MERGE_TYPE} != binary ]]; then
diff --git a/app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild
index 40bb28803b18..826ff08b2f51 100644
--- a/app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild
+++ b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
inherit flag-o-matic toolchain-funcs pax-utils
-DESCRIPTION="fast password cracker"
+DESCRIPTION="Fast password cracker"
HOMEPAGE="http://www.openwall.com/john/"
MY_PN="JohnTheRipper"
@@ -28,11 +28,12 @@ SLOT="0"
IUSE="custom-cflags kerberos mpi opencl openmp pcap"
DEPEND=">=dev-libs/openssl-1.0.1:0=
+ virtual/libcrypt:=
mpi? ( virtual/mpi )
opencl? ( virtual/opencl )
kerberos? ( virtual/krb5 )
pcap? ( net-libs/libpcap )
- dev-libs/gmp:*
+ dev-libs/gmp:=
sys-libs/zlib
app-arch/bzip2"