summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-10-09 11:21:20 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2018-10-09 11:21:32 +0300
commit2330941f1384f181b87568a88db33a9df5403dac (patch)
tree9bd3eee3ebd5a02315deacedf8c8a38923b382d4 /app-crypt/ssdeep/ssdeep-2.14.1.ebuild
parentapp-editors/okteta: 0.25.4 version bump (diff)
downloadgentoo-2330941f1384f181b87568a88db33a9df5403dac.tar.gz
gentoo-2330941f1384f181b87568a88db33a9df5403dac.tar.bz2
gentoo-2330941f1384f181b87568a88db33a9df5403dac.zip
app-crypt/ssdeep: version bump
Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'app-crypt/ssdeep/ssdeep-2.14.1.ebuild')
-rw-r--r--app-crypt/ssdeep/ssdeep-2.14.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-crypt/ssdeep/ssdeep-2.14.1.ebuild b/app-crypt/ssdeep/ssdeep-2.14.1.ebuild
new file mode 100644
index 000000000000..cd1c9c5b5c22
--- /dev/null
+++ b/app-crypt/ssdeep/ssdeep-2.14.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Computes context triggered piecewise hashes (fuzzy hashes)"
+HOMEPAGE="http://ssdeep.sourceforge.net/"
+SRC_URI="https://github.com/${PN}-project/${PN}/releases/download/release-${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DOCS=(
+ AUTHORS
+ ChangeLog
+ FILEFORMAT
+ NEWS
+ README
+ TODO
+)
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.10-shared.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+}