summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-28 00:27:30 +0100
committerSam James <sam@gentoo.org>2023-10-28 00:28:06 +0100
commit3fa119230469fdd809118a7136b4938abf0147dc (patch)
tree54a01356e77227fa6e1dbfbbbc32a4ad2b18c62a /app-crypt
parentapp-misc/vit: Version bump to 2.3.2 (diff)
downloadgentoo-3fa119230469fdd809118a7136b4938abf0147dc.tar.gz
gentoo-3fa119230469fdd809118a7136b4938abf0147dc.tar.bz2
gentoo-3fa119230469fdd809118a7136b4938abf0147dc.zip
app-crypt/p11-kit: add 0.25.1
Closes: https://bugs.gentoo.org/913971 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/p11-kit/Manifest1
-rw-r--r--app-crypt/p11-kit/files/p11-kit-0.25.1-skip-test-server.sh14
-rw-r--r--app-crypt/p11-kit/p11-kit-0.25.1.ebuild66
3 files changed, 81 insertions, 0 deletions
diff --git a/app-crypt/p11-kit/Manifest b/app-crypt/p11-kit/Manifest
index b9ce676ba163..a0b0b6d61de0 100644
--- a/app-crypt/p11-kit/Manifest
+++ b/app-crypt/p11-kit/Manifest
@@ -1 +1,2 @@
DIST p11-kit-0.25.0.tar.xz 958940 BLAKE2B 6ffce977f86c516a327afe50f4cc5a36e86ba7f43c6cb555db419d9e4ba7543a9f1847ba83da348cd6d7bbebe55dfa26cfe3a3aaa3e1d5420a4b8dc6cbbff088 SHA512 e6df3cb224f6ff5671bd3c0557503b5f20bbfded1b6ec340b1dafcbd1b1725ea2d41d0e920756716e0fe9cb28270d115fe77b23ec876a15007b22e3f30d015fe
+DIST p11-kit-0.25.1.tar.xz 990460 BLAKE2B 6704ef2ada20765bfbbbfc6f92ec2e934be34b482e1b6a94a7a15ab4718efcaecf943ce06b6c352b8c638fe2b1f0bc7c953c6b0dcf0590e5695c1d6724272ebb SHA512 e12e32148e0924ac7dca4c6a4399cff0934df4f002a31e7ffc5c3cfd14a4c0a47225eb84abd73b7f36c8dfcc32f92756e90699335b830414e8f5eddeaa42c532
diff --git a/app-crypt/p11-kit/files/p11-kit-0.25.1-skip-test-server.sh b/app-crypt/p11-kit/files/p11-kit-0.25.1-skip-test-server.sh
new file mode 100644
index 000000000000..db51edcd497c
--- /dev/null
+++ b/app-crypt/p11-kit/files/p11-kit-0.25.1-skip-test-server.sh
@@ -0,0 +1,14 @@
+diff --git a/p11-kit/test-server.sh b/p11-kit/test-server.sh
+index dcea45d..d6a9bfc 100755
+--- a/p11-kit/test-server.sh
++++ b/p11-kit/test-server.sh
+@@ -33,6 +33,9 @@ teardown() {
+ }
+
+ test_server_access() {
++ exit 77
++ return
++
+ "$abs_top_builddir"/p11-kit/p11-kit-server-testable -s --provider "$P11_MODULE_PATH"/mock-one.so pkcs11: > start.env 2> start.err
+ if test $? -ne 0; then
+ sed 's/^/# /' start.err
diff --git a/app-crypt/p11-kit/p11-kit-0.25.1.ebuild b/app-crypt/p11-kit/p11-kit-0.25.1.ebuild
new file mode 100644
index 000000000000..fe80f1e4c35b
--- /dev/null
+++ b/app-crypt/p11-kit/p11-kit-0.25.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit bash-completion-r1 meson-multilib python-any-r1
+
+DESCRIPTION="Provides a standard configuration setup for installing PKCS#11"
+HOMEPAGE="https://p11-glue.github.io/p11-glue/p11-kit.html"
+SRC_URI="https://github.com/p11-glue/p11-kit/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~m68k ~mips ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="+libffi gtk-doc nls systemd test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/ca-certificates
+ >=dev-libs/libtasn1-3.4:=[${MULTILIB_USEDEP}]
+ libffi? ( dev-libs/libffi:=[${MULTILIB_USEDEP}] )
+ systemd? ( sys-apps/systemd:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/castxml
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc )
+ nls? ( sys-devel/gettext )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.25.1-skip-test-server.sh
+)
+
+src_prepare() {
+ default
+
+ # Relies on dlopen which won't work for multilib tests (bug #913971)
+ cat <<-EOF > "${S}"/p11-kit/test-server.sh || die
+ #!/bin/sh
+ exit 77
+ EOF
+}
+
+multilib_src_configure() {
+ # Disable unsafe tests, bug#502088
+ export FAKED_MODE=1
+
+ local emesonargs=(
+ -Dbashcompdir="$(get_bashcompdir)"
+ -Dtrust_module=enabled
+ -Dtrust_paths="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt
+ $(meson_feature libffi)
+ $(meson_use nls)
+ $(meson_use test)
+ $(meson_native_use_bool gtk-doc gtk_doc)
+ $(meson_native_true man)
+ $(meson_native_use_feature systemd)
+ )
+
+ meson_src_configure
+}