summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-07-16 14:20:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-07-16 14:35:07 +0200
commitaeb647b0b5d1bc3e3f1df2c565534ee8695d8dff (patch)
tree23783da806f38ab8b86c31f6de6f6cd7cbb93426 /app-crypt
parentdev-libs/dbus-glib: 0.112 version bump (diff)
downloadgentoo-aeb647b0b5d1bc3e3f1df2c565534ee8695d8dff.tar.gz
gentoo-aeb647b0b5d1bc3e3f1df2c565534ee8695d8dff.tar.bz2
gentoo-aeb647b0b5d1bc3e3f1df2c565534ee8695d8dff.zip
app-crypt/libmd: EAPI-8 bump, multilib support
Required by >=dev-libs/libbsd-0.11.3. Bug: https://bugs.gentoo.org/789009 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/libmd/libmd-1.0.3-r1.ebuild23
-rw-r--r--app-crypt/libmd/libmd-9999.ebuild14
2 files changed, 29 insertions, 8 deletions
diff --git a/app-crypt/libmd/libmd-1.0.3-r1.ebuild b/app-crypt/libmd/libmd-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..eedd72789dfb
--- /dev/null
+++ b/app-crypt/libmd/libmd-1.0.3-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="Message Digest functions from BSD systems"
+HOMEPAGE="https://www.hadrons.org/software/libmd/"
+SRC_URI="https://archive.hadrons.org/software/libmd/${P}.tar.xz"
+
+LICENSE="|| ( BSD BSD-2 ISC BEER-WARE public-domain )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+multilib_src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+}
diff --git a/app-crypt/libmd/libmd-9999.ebuild b/app-crypt/libmd/libmd-9999.ebuild
index 7ce508a893c1..b28c93edaff6 100644
--- a/app-crypt/libmd/libmd-9999.ebuild
+++ b/app-crypt/libmd/libmd-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools git-r3
+inherit autotools multilib-minimal git-r3
DESCRIPTION="Message Digest functions from BSD systems"
HOMEPAGE="https://www.hadrons.org/software/libmd/"
@@ -14,16 +14,14 @@ SLOT="0"
src_prepare() {
default
-
eautoreconf
}
-src_configure() {
- econf --disable-static
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
}
-src_install() {
+multilib_src_install() {
default
-
- find "${ED}" -name '*.la' -delete || die
+ find "${ED}" -type f -name "*.la" -delete || die
}