summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew White <mehw.is.me@inventati.org>2023-08-01 14:41:23 +0000
committerSam James <sam@gentoo.org>2024-03-23 08:29:09 +0000
commite04e0ee75ec9a30fada6d3670283804c24d47712 (patch)
tree3ab2d6925c4da48f8664ee42c14f1ce9f20138cb /app-doc/audacity/audacity-3.3.3.ebuild
parentmedia-sound/audacity: drop 3.2.5-r1 (diff)
downloadgentoo-e04e0ee75ec9a30fada6d3670283804c24d47712.tar.gz
gentoo-e04e0ee75ec9a30fada6d3670283804c24d47712.tar.bz2
gentoo-e04e0ee75ec9a30fada6d3670283804c24d47712.zip
app-doc/audacity: HTML reference manual for Audacity
Closes: https://bugs.gentoo.org/911561 Package-Manager: portage-3.0.49-r1 Signed-off-by: Matthew White <mehw.is.me@inventati.org> Closes: https://github.com/gentoo/gentoo/pull/32128 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-doc/audacity/audacity-3.3.3.ebuild')
-rw-r--r--app-doc/audacity/audacity-3.3.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-doc/audacity/audacity-3.3.3.ebuild b/app-doc/audacity/audacity-3.3.3.ebuild
new file mode 100644
index 000000000000..c033739b6a0e
--- /dev/null
+++ b/app-doc/audacity/audacity-3.3.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="HTML reference manual for Audacity"
+HOMEPAGE="https://www.audacityteam.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/audacity/audacity-manual.git"
+else
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/help"
+ SRC_URI="amd64? ( https://github.com/audacity/audacity-manual/releases/download/v${PV}/audacity-manual-${PV}.tar.gz )"
+fi
+
+LICENSE="CC-BY-3.0"
+SLOT="0"
+
+src_install() {
+ docinto html
+ dodoc -r "${S}"/manual/{m,man}
+ dodoc "${S}"/manual/{favicon.ico,index.html,quick_help.html}
+ dosym ../../doc/${PF}/html /usr/share/${PN}/help/manual
+}