summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-02-25 11:58:34 +0100
committerUlrich Müller <ulm@gentoo.org>2023-02-25 17:08:45 +0100
commit6b239f9d6f53f9270ae3a64b184a097b7bbeacb5 (patch)
treedd030b9aa92f5ebc62b890aec1eb3a80600806e9 /app-doc/devmanual
parentsys-libs/glibc: bump 2.37 patchset to version 3 (diff)
downloadgentoo-6b239f9d6f53f9270ae3a64b184a097b7bbeacb5.tar.gz
gentoo-6b239f9d6f53f9270ae3a64b184a097b7bbeacb5.tar.bz2
gentoo-6b239f9d6f53f9270ae3a64b184a097b7bbeacb5.zip
app-doc/devmanual: New snapshot 0_pre20230121
Update for Python 3.11. Closes: https://bugs.gentoo.org/896520 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-doc/devmanual')
-rw-r--r--app-doc/devmanual/Manifest1
-rw-r--r--app-doc/devmanual/devmanual-0_pre20230121.ebuild60
-rw-r--r--app-doc/devmanual/devmanual-9999.ebuild2
3 files changed, 62 insertions, 1 deletions
diff --git a/app-doc/devmanual/Manifest b/app-doc/devmanual/Manifest
index 0f08e214609c..7e5d6f73b27c 100644
--- a/app-doc/devmanual/Manifest
+++ b/app-doc/devmanual/Manifest
@@ -1,2 +1,3 @@
DIST devmanual-0_pre20220326.tar.xz 183228 BLAKE2B 67ab1a24e8f1043f2d7938a76f4d819ecfaffaf3516cf5ce9eff20ac0e481c60be06c83c4adc3835e6ee66c44def290aa682567662dbf7a7a7057b0d168e1677 SHA512 364fe3504ba424201b450e08fe2043e55d1067c3603c4d3248112117461a4ab667d50f82deac9daaf50e28ea5d996c1ae08668d55b7379915cc175f66edddf9b
DIST devmanual-0_pre20220625.tar.xz 185236 BLAKE2B 3fb6bc0ec184c611fb10aa3062ffc7cd12e1d77a5a093fd13f7958fbf3494c42dc9674e10164c67080d1b5af1dcdc2fa09c017aeaec77e09fdd87cf63556b4c8 SHA512 46f44a9d77b0f433b9f8bbe48f1a2c9871c00a78f9726b7bed8aebb1e389898e0ddcbcee313ff277fc3946b3b2d46b5a23227c4f6d41cee467605086c182ba56
+DIST devmanual-0_pre20230121.tar.xz 185536 BLAKE2B e099b3644ee84148f6ab7630934beb80420501aae76774949ec16529d64716c09bfc26a0e7a3641c5cc2809adbf00e5560b04182840799e229b30182e4920dd6 SHA512 370cb49d5b257f8efc872bc5c85a53aabb3a01fc0fc8d1f65144e27a5ff578286a25987e62fc9874dfdda7bf4864e7921d31e97f43db12e75bd59b429314d369
diff --git a/app-doc/devmanual/devmanual-0_pre20230121.ebuild b/app-doc/devmanual/devmanual-0_pre20230121.ebuild
new file mode 100644
index 000000000000..f48fa93aeb42
--- /dev/null
+++ b/app-doc/devmanual/devmanual-0_pre20230121.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10,11} )
+PYTHON_REQ_USE="xml(+)"
+inherit python-any-r1 readme.gentoo-r1
+
+DESCRIPTION="The Gentoo Development Guide"
+HOMEPAGE="https://devmanual.gentoo.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/devmanual.git"
+else
+ # "make dist" in devmanual repo
+ SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+ S="${WORKDIR}/${PN}"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+fi
+
+LICENSE="CC-BY-SA-4.0"
+SLOT="0"
+IUSE="+offline test"
+RESTRICT="!test? ( test )"
+
+BDEPEND=">=dev-libs/libxml2-2.9.12
+ dev-libs/libxslt
+ gnome-base/librsvg
+ media-fonts/open-sans
+ ${PYTHON_DEPS}
+ test? ( >=app-text/htmltidy-5.8.0 )"
+
+PATCHES=( "${FILESDIR}"/${PN}-eclasses.patch )
+
+src_compile() {
+ emake OFFLINE=$(usex offline 1 0)
+}
+
+src_install() {
+ emake OFFLINE=$(usex offline 1 0) \
+ DESTDIR="${D}" \
+ htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ install
+
+ local DOC_CONTENTS="In order to browse the Gentoo Development Guide in
+ offline mode, point your browser to the following url:
+ file://${EPREFIX}/usr/share/doc/${PF}/html/index.html"
+ if ! has_version app-doc/eclass-manpages; then
+ DOC_CONTENTS+="\\n\\nThe offline version of the devmanual does not
+ include the documentation for the eclasses. If you need it,
+ then emerge app-doc/eclass-manpages."
+ fi
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/app-doc/devmanual/devmanual-9999.ebuild b/app-doc/devmanual/devmanual-9999.ebuild
index 78dd10aef4b8..f48fa93aeb42 100644
--- a/app-doc/devmanual/devmanual-9999.ebuild
+++ b/app-doc/devmanual/devmanual-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9,10,11} )
PYTHON_REQ_USE="xml(+)"
inherit python-any-r1 readme.gentoo-r1