summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-05-10 12:22:55 +0200
committerUlrich Müller <ulm@gentoo.org>2020-05-10 12:24:00 +0200
commit986be7e739caf0134614da3d1d647ae92c473a3b (patch)
treeca10e1aa17f4e8de8d4e48fca8276c6723336466 /app-editors/e3/e3-2.8.2.ebuild
parentapp-editors/fe: Call tc-getAR to determine the ar program. (diff)
downloadgentoo-986be7e739caf0134614da3d1d647ae92c473a3b.tar.gz
gentoo-986be7e739caf0134614da3d1d647ae92c473a3b.tar.bz2
gentoo-986be7e739caf0134614da3d1d647ae92c473a3b.zip
app-editors/e3: Call tc-getLD to determine the ld program.
Closes: https://bugs.gentoo.org/722050 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors/e3/e3-2.8.2.ebuild')
-rw-r--r--app-editors/e3/e3-2.8.2.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/app-editors/e3/e3-2.8.2.ebuild b/app-editors/e3/e3-2.8.2.ebuild
index 4d675fa1428c..41f1d83154db 100644
--- a/app-editors/e3/e3-2.8.2.ebuild
+++ b/app-editors/e3/e3-2.8.2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
+
MY_P="${PN}-$(ver_rs 2 '')"
DESCRIPTION="Very tiny editor in ASM with emacs, pico, wordstar, and vi keybindings"
HOMEPAGE="https://sites.google.com/site/e3editor/"
@@ -16,14 +18,10 @@ RESTRICT="strip"
BDEPEND=">=dev-lang/nasm-2.09.04"
S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- sed -i 's/-D$(EXMODE)//' Makefile || die
- eapply_user
-}
+PATCHES=("${FILESDIR}"/${P}-makefile.patch)
src_compile() {
- emake -- $(usex amd64 64 32)
+ emake -- $(usex amd64 64 32) LD="$(tc-getLD)"
}
src_install() {