summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-02-15 19:36:47 +0100
committerUlrich Müller <ulm@gentoo.org>2022-02-15 19:48:58 +0100
commita4ff1a1c9a66a3a659358b88b3546f04783285c6 (patch)
treeb71a43fff31531fb1ee1604f40af6173738784ab /app-editors/jove/jove-4.17.3.7.ebuild
parentwww-client/chromium: fix building with gtk4 (diff)
downloadgentoo-a4ff1a1c9a66a3a659358b88b3546f04783285c6.tar.gz
gentoo-a4ff1a1c9a66a3a659358b88b3546f04783285c6.tar.bz2
gentoo-a4ff1a1c9a66a3a659358b88b3546f04783285c6.zip
app-editors/jove: Version bump to 4.17.3.7
Upstream labels this as a pre-release, so it is _not_ a candidate for stabilisation. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors/jove/jove-4.17.3.7.ebuild')
-rw-r--r--app-editors/jove/jove-4.17.3.7.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-editors/jove/jove-4.17.3.7.ebuild b/app-editors/jove/jove-4.17.3.7.ebuild
new file mode 100644
index 000000000000..3c41a1a75685
--- /dev/null
+++ b/app-editors/jove/jove-4.17.3.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Jonathan's Own Version of Emacs, a light emacs-like editor without LISP bindings"
+HOMEPAGE="https://github.com/jonmacs/jove"
+SRC_URI="https://github.com/jonmacs/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="JOVE"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_compile() {
+ tc-export CC
+
+ emake \
+ JOVEHOME="${EPREFIX}/usr" \
+ JMANDIR="${EPREFIX}/usr/share/man/man1" \
+ OPTFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ SYSDEFS="-DLinux" \
+ TERMCAPLIB="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
+
+ if use doc; then
+ # Full manual (*not* man page)
+ emake doc/jove.man
+ fi
+}
+
+src_install() {
+ emake \
+ JOVEHOME="${EPREFIX}/usr" \
+ JMANDIR="${EPREFIX}/usr/share/man/man1" \
+ DESTDIR="${D}" \
+ install
+ keepdir /var/lib/jove/preserve
+
+ dodoc README
+ if use doc; then
+ dodoc doc/jove.man
+ fi
+}