summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Günzler <r@gnzler.io>2022-08-01 21:19:41 +0300
committerSam James <sam@gentoo.org>2022-08-13 13:14:29 +0100
commit89652dfc4741375f7efbbaf5113f04cf63b53a56 (patch)
treec9860dd8bbe77b6583d0da2d8fb74b3aab679ff1 /app-editors/neovim
parentdev-python/cmd2: Stabilize 2.4.2 ALLARCHES, #865085 (diff)
downloadgentoo-89652dfc4741375f7efbbaf5113f04cf63b53a56.tar.gz
gentoo-89652dfc4741375f7efbbaf5113f04cf63b53a56.tar.bz2
gentoo-89652dfc4741375f7efbbaf5113f04cf63b53a56.zip
app-editors/neovim: rebase patches
Signed-off-by: Robert Günzler <r@gnzler.io> Closes: https://github.com/gentoo/gentoo/pull/26698 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/neovim')
-rw-r--r--app-editors/neovim/files/neovim-9999-cmake-darwin.patch14
-rw-r--r--app-editors/neovim/files/neovim-9999-cmake-release-type.patch13
-rw-r--r--app-editors/neovim/files/neovim-9999-cmake_lua_version.patch2
-rw-r--r--app-editors/neovim/neovim-9999.ebuild6
4 files changed, 29 insertions, 6 deletions
diff --git a/app-editors/neovim/files/neovim-9999-cmake-darwin.patch b/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
index 5b829904a13e..cf3e05716625 100644
--- a/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
+++ b/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
@@ -1,6 +1,6 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -80,23 +80,6 @@ set(ENV{PKG_CONFIG_PATH} "$ENV{PKG_CONFIG_PATH}:${DEPS_PREFIX}/lib/pkgconfig")
+@@ -80,33 +80,6 @@ set(ENV{PKG_CONFIG_PATH} "$ENV{PKG_CONFIG_PATH}:${DEPS_PREFIX}/lib/pkgconfig")
# used for check_c_compiler_flag
include(CheckCCompilerFlag)
@@ -13,6 +13,16 @@
- # them be included as one of the first places to look for dependencies.
- list(APPEND CMAKE_PREFIX_PATH /sw /opt/local)
-
+- # If the macOS deployment target is not set manually (via $MACOSX_DEPLOYMENT_TARGET),
+- # fall back to local system version. Needs to be done both here and in cmake.deps.
+- if(NOT CMAKE_OSX_DEPLOYMENT_TARGET)
+- execute_process(COMMAND sw_vers -productVersion
+- OUTPUT_VARIABLE MACOS_VERSION
+- OUTPUT_STRIP_TRAILING_WHITESPACE)
+- set(CMAKE_OSX_DEPLOYMENT_TARGET "${MACOS_VERSION}")
+- endif()
+- message("Using deployment target ${CMAKE_OSX_DEPLOYMENT_TARGET}")
+-
- # Work around some old, broken detection by CMake for knowing when to use the
- # isystem flag. Apple's compilers have supported this for quite some time
- # now.
@@ -42,7 +52,7 @@
# The LuaJIT build does not like being passed multiple `-arch` flags
--- a/src/nvim/CMakeLists.txt
+++ b/src/nvim/CMakeLists.txt
-@@ -205,10 +205,6 @@ get_directory_property(gen_includes INCLUDE_DIRECTORIES)
+@@ -181,10 +181,6 @@ get_directory_property(gen_includes INCLUDE_DIRECTORIES)
foreach(gen_include ${gen_includes} ${LUA_PREFERRED_INCLUDE_DIRS})
list(APPEND gen_cflags "-I${gen_include}")
endforeach()
diff --git a/app-editors/neovim/files/neovim-9999-cmake-release-type.patch b/app-editors/neovim/files/neovim-9999-cmake-release-type.patch
new file mode 100644
index 000000000000..1d7fb56b51c8
--- /dev/null
+++ b/app-editors/neovim/files/neovim-9999-cmake-release-type.patch
@@ -0,0 +1,13 @@
+Ensure that :checkhealth is happy with the Gentoo build type.
+https://bugs.gentoo.org/757744
+--- a/runtime/autoload/health/nvim.vim
++++ b/runtime/autoload/health/nvim.vim
+@@ -135,7 +135,7 @@ function! s:check_performance() abort
+ let buildtype = matchstr(execute('version'), '\v\cbuild type:?\s*[^\n\r\t ]+')
+ if empty(buildtype)
+ call health#report_error('failed to get build type from :version')
+- elseif buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo)'
++ elseif buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo|Gentoo)'
+ call health#report_ok(buildtype)
+ else
+ call health#report_info(buildtype)
diff --git a/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch b/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch
index d7e01275fb02..87a898032493 100644
--- a/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch
+++ b/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch
@@ -1,6 +1,6 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -384,7 +384,7 @@
+@@ -464,7 +464,7 @@ endif()
option(PREFER_LUA "Prefer Lua over LuaJIT in the nvim executable." OFF)
if(PREFER_LUA)
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index dc40449cb307..c1e19411b835 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -66,18 +66,18 @@ BDEPEND="
)
"
-PATCHES=(
- "${FILESDIR}/${PN}-0.4.4-cmake-release-type.patch"
-)
+PATCHES=()
if [[ ${PV} == 9999 ]]; then
PATCHES+=(
"${FILESDIR}/${PN}-9999-cmake_lua_version.patch"
+ "${FILESDIR}/${PN}-9999-cmake-release-type.patch"
"${FILESDIR}/${PN}-9999-cmake-darwin.patch"
)
else
PATCHES+=(
"${FILESDIR}/${PN}-0.4.4-cmake_lua_version.patch"
+ "${FILESDIR}/${PN}-0.4.4-cmake-release-type.patch"
"${FILESDIR}/${PN}-0.7.2-cmake-darwin.patch"
)
fi