summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-03 09:26:59 +0100
committerSam James <sam@gentoo.org>2022-06-03 09:26:59 +0100
commit75a0c76e46b055884379160d1adf1e087ef0ad26 (patch)
tree37f97a58a0db49dc7a67da66cb072d1623d202aa /app-editors/retext
parentmedia-gfx/inkscape: add missing dev-python/cssselect dep (diff)
downloadgentoo-75a0c76e46b055884379160d1adf1e087ef0ad26.tar.gz
gentoo-75a0c76e46b055884379160d1adf1e087ef0ad26.tar.bz2
gentoo-75a0c76e46b055884379160d1adf1e087ef0ad26.zip
app-editors/retext: add 7.2.3
Closes: https://bugs.gentoo.org/848999 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/retext')
-rw-r--r--app-editors/retext/Manifest1
-rw-r--r--app-editors/retext/retext-7.2.3.ebuild74
-rw-r--r--app-editors/retext/retext-9999.ebuild26
3 files changed, 90 insertions, 11 deletions
diff --git a/app-editors/retext/Manifest b/app-editors/retext/Manifest
index 613d0808a019..170590d8d240 100644
--- a/app-editors/retext/Manifest
+++ b/app-editors/retext/Manifest
@@ -1 +1,2 @@
DIST ReText-7.2.2.tar.gz 522652 BLAKE2B f9b19f985c1381eade324758c4dc6bf2e5f74bc3f5bfc27afa10462b7387f64a3e72edd5875aabf1831f1f0a942f395e43b124c172cac8cec4b9f19334661484 SHA512 68345b57b2c5446158ed3a6f97b5ead103ef1c99a3aea9cbc69ef7d0807fb64546f38ebde2969b94429eeed6450abb345fecc566dcf6e0767fe84c4e27348e53
+DIST ReText-7.2.3.tar.gz 527428 BLAKE2B 3c710769a881275d74018ba319b174020dda0b65da22ae926231af56901b56c31b3cff69119a9bb378cd218d7b793f002bb08bf1483cc1e55c95a4963cbe1598 SHA512 eb337866f5dfacad2f23435f09b550f4378df5bb261d6f79b1708fed9e7bd93e96e8f06f940cb7109fe02aa6df0592b151f11dfe13853799f0b1ac2c1065a0da
diff --git a/app-editors/retext/retext-7.2.3.ebuild b/app-editors/retext/retext-7.2.3.ebuild
new file mode 100644
index 000000000000..214372f2d90a
--- /dev/null
+++ b/app-editors/retext/retext-7.2.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Please don't add pypy support before testing if it's actually supported. The
+# old compat matrix is no longer accessible as of 2021-02-13 but stated back
+# in 2020-07-05 that PyQt5 was explicitly not supported.
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit distutils-r1 optfeature qmake-utils virtualx xdg
+
+MY_PN="ReText"
+MY_P="${MY_PN}-${PV/_/~}"
+
+DESCRIPTION="Simple editor for Markdown and reStructuredText"
+HOMEPAGE="https://github.com/retext-project/retext https://github.com/retext-project/retext/wiki"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/retext-project/retext.git"
+else
+ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+
+ KEYWORDS="~amd64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ >=dev-python/markups-3.1.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/python-markdown-math[${PYTHON_USEDEP}]
+ dev-python/PyQt5[dbus,gui,printsupport,widgets,${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-qt/linguist-tools
+ test? ( dev-python/PyQt5[testlib,${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests unittest
+
+pkg_setup() {
+ # Needed for lrelease
+ export PATH="$(qt5_get_bindir):${PATH}"
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ eunittest || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "dictionary support" dev-python/pyenchant
+ # See https://bugs.gentoo.org/772197.
+ optfeature "rendering with webengine" dev-python/PyQtWebEngine
+
+ einfo "Starting with retext-7.0.4 the markdown-math plugin is installed."
+ einfo "Note that you can use different math delimiters, e.g. \(...\) for inline math."
+ einfo "For more details take a look at:"
+ einfo "https://github.com/mitya57/python-markdown-math#math-delimiters"
+}
diff --git a/app-editors/retext/retext-9999.ebuild b/app-editors/retext/retext-9999.ebuild
index ac4f08fb2467..214372f2d90a 100644
--- a/app-editors/retext/retext-9999.ebuild
+++ b/app-editors/retext/retext-9999.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
# Please don't add pypy support before testing if it's actually supported. The
# old compat matrix is no longer accessible as of 2021-02-13 but stated back
# in 2020-07-05 that PyQt5 was explicitly not supported.
PYTHON_COMPAT=( python3_{8,9,10} )
-inherit distutils-r1 optfeature virtualx xdg-utils
+inherit distutils-r1 optfeature qmake-utils virtualx xdg
MY_PN="ReText"
MY_P="${MY_PN}-${PV/_/~}"
@@ -40,19 +40,28 @@ RDEPEND="
dev-python/PyQt5[dbus,gui,printsupport,widgets,${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
-BDEPEND="test? ( dev-python/PyQt5[testlib,${PYTHON_USEDEP}] )"
+BDEPEND="
+ dev-qt/linguist-tools
+ test? ( dev-python/PyQt5[testlib,${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests unittest
+
+pkg_setup() {
+ # Needed for lrelease
+ export PATH="$(qt5_get_bindir):${PATH}"
+}
src_test() {
virtx distutils-r1_src_test
}
python_test() {
- esetup.py test
+ eunittest || die
}
pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
+ xdg_pkg_postinst
optfeature "dictionary support" dev-python/pyenchant
# See https://bugs.gentoo.org/772197.
@@ -63,8 +72,3 @@ pkg_postinst() {
einfo "For more details take a look at:"
einfo "https://github.com/mitya57/python-markdown-math#math-delimiters"
}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-}