summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-01-13 20:29:32 -0500
committerTim Harder <radhermit@gentoo.org>2016-01-13 20:34:42 -0500
commit2e080cedaaab9f1249fcdd6c7354bd35d1b91082 (patch)
treed78de02aeb0a28f6324e93be21dbbc4f10c251bf /app-editors/vim/vim-9999.ebuild
parentapp-editors/vim-core: version bump to 7.4.1089 (diff)
downloadgentoo-2e080cedaaab9f1249fcdd6c7354bd35d1b91082.tar.gz
gentoo-2e080cedaaab9f1249fcdd6c7354bd35d1b91082.tar.bz2
gentoo-2e080cedaaab9f1249fcdd6c7354bd35d1b91082.zip
app-editors/vim: version bump to 7.4.1089
Diffstat (limited to 'app-editors/vim/vim-9999.ebuild')
-rw-r--r--app-editors/vim/vim-9999.ebuild28
1 files changed, 4 insertions, 24 deletions
diff --git a/app-editors/vim/vim-9999.ebuild b/app-editors/vim/vim-9999.ebuild
index a6f60aa412b9..b662c4c43a4b 100644
--- a/app-editors/vim/vim-9999.ebuild
+++ b/app-editors/vim/vim-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
VIM_VERSION="7.4"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
PYTHON_REQ_USE=threads
inherit eutils vim-doc flag-o-matic fdo-mime versionator bash-completion-r1 python-r1
@@ -34,7 +34,7 @@ REQUIRED_USE="
RDEPEND="
>=app-eselect/eselect-vi-1.1
- >=sys-libs/ncurses-5.2-r2
+ >=sys-libs/ncurses-5.2-r2:0
nls? ( virtual/libintl )
acl? ( kernel_linux? ( sys-apps/acl ) )
cscope? ( dev-util/cscope )
@@ -50,7 +50,7 @@ RDEPEND="
perl? ( dev-lang/perl:= )
python? ( ${PYTHON_DEPS} )
racket? ( dev-scheme/racket )
- ruby? ( || ( dev-lang/ruby:2.2 dev-lang/ruby:2.1 dev-lang/ruby:2.0 ) )
+ ruby? ( || ( dev-lang/ruby:2.3 dev-lang/ruby:2.2 dev-lang/ruby:2.1 dev-lang/ruby:2.0 ) )
selinux? ( sys-libs/libselinux )
tcl? ( dev-lang/tcl:0= )
X? ( x11-libs/libXt )
@@ -351,26 +351,6 @@ pkg_postinst() {
# Update documentation tags (from vim-doc.eclass)
update_vim_helptags
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- if use X ; then
- echo
- elog "The 'X' USE flag enables vim <-> X communication, like"
- elog "updating the xterm titlebar. It does not install a GUI."
- fi
- echo
- elog "To install a GUI version of vim, use the app-editors/gvim"
- elog "package."
- echo
- elog "Vim 7 includes an integrated spell checker. You need to install"
- elog "word list files before you can use it. There are ebuilds for"
- elog "some of these named app-vim/vim-spell-*. If your language of"
- elog "choice is not included, please consult vim-spell.eclass for"
- elog "instructions on how to make a package."
- echo
- ewarn "Note that the English word lists are no longer installed by"
- ewarn "default."
- fi
-
# Make convenience symlinks
update_vim_symlinks
}