summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-12-18 18:04:49 +0000
committerArthur Zamarin <arthurzam@gentoo.org>2024-12-18 18:05:46 +0000
commitc7b4cbbbd107f915f5f051bac6346c3e68c7b72f (patch)
treeebc0d50e374430455f89ef792e881d85d8d9cde0 /app-editors/vscode
parentdev-python/jupyterlab: add 4.3.3 (diff)
downloadgentoo-c7b4cbbbd107f915f5f051bac6346c3e68c7b72f.tar.gz
gentoo-c7b4cbbbd107f915f5f051bac6346c3e68c7b72f.tar.bz2
gentoo-c7b4cbbbd107f915f5f051bac6346c3e68c7b72f.zip
app-editors/vscode: add 1.96.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors/vscode')
-rw-r--r--app-editors/vscode/Manifest3
-rw-r--r--app-editors/vscode/vscode-1.96.1.ebuild131
2 files changed, 134 insertions, 0 deletions
diff --git a/app-editors/vscode/Manifest b/app-editors/vscode/Manifest
index b19c61b8860b..cacf5ac16c4e 100644
--- a/app-editors/vscode/Manifest
+++ b/app-editors/vscode/Manifest
@@ -7,3 +7,6 @@ DIST vscode-1.95.3-arm64.tar.gz 144398988 BLAKE2B 2bae1b98e3bcb5c3bab388035b5b0b
DIST vscode-1.96.0-amd64.tar.gz 149448388 BLAKE2B ab54f0044d819a76acfb9f637a15c7118db30f5b1f84df622b8aa48aca7cbffa85115f187990c16105c8548ea1a1caa29f18fbb395f307710c8d273c6fd3a300 SHA512 9ac57fc51c42bd62aa3094be5f5184c194255af9a32b5454b66d648f7f315b2323717fce50637debd0d6ec5f9bb94ba9366b92eec6d06e952bb2c52a37dbc77a
DIST vscode-1.96.0-arm.tar.gz 133515870 BLAKE2B addead61ed9dc147f28e3fd0f2bf49036d24bd0301a1fd6fc014743af72d0c3b10c8e1e515a31b50d030e2642eda325d02110fab245c3ec4635485aae8243f40 SHA512 8b110086e94b88093909724b14653394c91e6047560c4090c5e1e9c0d84dbe1525b9281c1e60fdb70675fb5588bc031028207f3f4d3ca11069c3e7bac51301ec
DIST vscode-1.96.0-arm64.tar.gz 145446774 BLAKE2B 985a06ac1a3aae33b308dab803901ca468752a92474a9983a0c9e61d257c9e18d9d60114b7ed6dbd8d71d563695931863fcf1ef20872d2644c61a0b3bdc69257 SHA512 8c0a53506b4992ec4b3ed9655bee6cccea89a1b7e29dc9baca6af7656383b10562707f14820bfbe48bf74defcba294ecfe7751cac7063ede9082a1484d4fba0d
+DIST vscode-1.96.1-amd64.tar.gz 149426003 BLAKE2B 0de1b15b5858faaa7293f1991a75f1e1317f62c5479235f8c4b0d4dfbe5e07db7dcb57002b1889be80979a65c31ca6069d94f5486628ef0cb14a144f8df9a082 SHA512 c4190963437c8b10f6ee03ad38c91bbaf710f35017c9ef0547836df9deba462ee2da2e0262669dfc494bacdb3e175ae1e83138d977538c190521e35441b2f57a
+DIST vscode-1.96.1-arm.tar.gz 133485634 BLAKE2B b384ea0163106f0074a7f156319a17398f1d0780b2698abcd4f9ba16df07d2c252e27db2710876928a286f259b07586b560d9fafbef02bd0161daa102c0d1d8f SHA512 cd68531c9c90aaa76a4289e87e377ca7de5e1a721db27d169aad95e3319d312cae3ced447b6405f23b6f3a4b8fc40ea3830ed6039c4785b67f9a72f483809aee
+DIST vscode-1.96.1-arm64.tar.gz 145430910 BLAKE2B 31a6883572c2e34f7d8b301f3e2e1f82ca48f37c55df1156a6a1c0d4f51cb9a2f7e00694b102bdd70063a65eb3a2d3b685b992dd9fb87e9e8c5421e20a283b7a SHA512 dc92380bcfd4a08ffa6ec56a5df99fa36b43282ea8de1243bd7d171b24d7afe33eec02fd3b56a17372a8400bf293ec2ace1b8ebe6f92b5d9177239dd26a35c40
diff --git a/app-editors/vscode/vscode-1.96.1.ebuild b/app-editors/vscode/vscode-1.96.1.ebuild
new file mode 100644
index 000000000000..7757235fed73
--- /dev/null
+++ b/app-editors/vscode/vscode-1.96.1.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+DESCRIPTION="Multiplatform Visual Studio Code from Microsoft"
+HOMEPAGE="https://code.visualstudio.com"
+SRC_URI="
+ amd64? ( https://update.code.visualstudio.com/${PV}/linux-x64/stable -> ${P}-amd64.tar.gz )
+ arm? ( https://update.code.visualstudio.com/${PV}/linux-armhf/stable -> ${P}-arm.tar.gz )
+ arm64? ( https://update.code.visualstudio.com/${PV}/linux-arm64/stable -> ${P}-arm64.tar.gz )
+"
+S="${WORKDIR}"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ Microsoft-vscode
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* amd64 ~arm ~arm64"
+IUSE="egl kerberos wayland"
+RESTRICT="mirror strip bindist"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ app-misc/ca-certificates
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/libglvnd
+ media-libs/mesa
+ net-misc/curl
+ sys-apps/dbus
+ sys-libs/zlib
+ sys-process/lsof
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+ x11-misc/xdg-utils
+ kerberos? ( app-crypt/mit-krb5 )
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ if use amd64; then
+ cd "${WORKDIR}/VSCode-linux-x64" || die
+ elif use arm; then
+ cd "${WORKDIR}/VSCode-linux-armhf" || die
+ elif use arm64; then
+ cd "${WORKDIR}/VSCode-linux-arm64" || die
+ else
+ die "Visual Studio Code only supports amd64, arm and arm64"
+ fi
+
+ # Cleanup
+ rm -r ./resources/app/ThirdPartyNotices.txt || die
+
+ # Disable update server
+ sed -e "/updateUrl/d" -i ./resources/app/product.json || die
+
+ if ! use kerberos; then
+ rm -r ./resources/app/node_modules/kerberos || die
+ fi
+
+ # Install
+ pax-mark m code
+ mkdir -p "${ED}/opt/${PN}" || die
+ cp -r . "${ED}/opt/${PN}" || die
+ fperms 4711 /opt/${PN}/chrome-sandbox
+
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/vscode"
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/code"
+
+ local EXEC_EXTRA_FLAGS=()
+ if use wayland; then
+ EXEC_EXTRA_FLAGS+=( "--ozone-platform-hint=auto" "--enable-wayland-ime" )
+ fi
+ if use egl; then
+ EXEC_EXTRA_FLAGS+=( "--use-gl=egl" )
+ fi
+
+ sed "s|@exec_extra_flags@|${EXEC_EXTRA_FLAGS[*]}|g" \
+ "${FILESDIR}/code-url-handler.desktop" \
+ > "${T}/code-url-handler.desktop" || die
+
+ sed "s|@exec_extra_flags@|${EXEC_EXTRA_FLAGS[*]}|g" \
+ "${FILESDIR}/code.desktop" \
+ > "${T}/code.desktop" || die
+
+ domenu "${T}/code.desktop"
+ domenu "${T}/code-url-handler.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscode.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "desktop notifications" x11-libs/libnotify
+ optfeature "keyring support inside vscode" "virtual/secret-service"
+}