summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2022-10-05 19:04:55 -0300
committerMatt Turner <mattst88@gentoo.org>2022-10-05 22:03:45 -0400
commit089c2328abf644ca1184b11b60aad18d66b30cd5 (patch)
treeff4457cacdeaee4eb340362d9d4f310d9096e363 /app-editors
parentapp-editors/ghex: Update live ebuild (diff)
downloadgentoo-089c2328abf644ca1184b11b60aad18d66b30cd5.tar.gz
gentoo-089c2328abf644ca1184b11b60aad18d66b30cd5.tar.bz2
gentoo-089c2328abf644ca1184b11b60aad18d66b30cd5.zip
app-editors/ghex: Version bump to 43.0
Closes: https://github.com/gentoo/gentoo/pull/27650 Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/ghex/Manifest1
-rw-r--r--app-editors/ghex/ghex-43.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-editors/ghex/Manifest b/app-editors/ghex/Manifest
index b5d3f2a43f36..1c1f423b2e2d 100644
--- a/app-editors/ghex/Manifest
+++ b/app-editors/ghex/Manifest
@@ -1 +1,2 @@
DIST ghex-42.3.tar.xz 1003928 BLAKE2B 26bb123fc5a56fc2ff891a057ac276a36bc500a2e23f29bd26a85d6888035e2b8af7aed7f7b679a898c0a98bf042bb4e05c66e55a8fac0eb63422ee03823dc74 SHA512 9eff44892d203a2a9aab7239d85f61a860458fd7a8b4d7410f94d4f596ca5e2ff269faa81e620e7fc08bebe40c819a4c0cafefb5278121a9f2c8885bfd17c59f
+DIST ghex-43.0.tar.xz 1020716 BLAKE2B e4b6590f9af11d6fbec31266ef9959b827937697eebd02a942b85e0c0d51555ced79ab84b34c4ab42b5cbb6d6071390d00cd0177e7e712e33e240b3132749a19 SHA512 4150d33ea1dc40d0c051ba1ba4a4829d084a4aa6ed682bade5b3e039a90049c4d009183e78b06768946b516386aa9e41b888eca61c40d96336d7ab4dd37b395b
diff --git a/app-editors/ghex/ghex-43.0.ebuild b/app-editors/ghex/ghex-43.0.ebuild
new file mode 100644
index 000000000000..e0eb24528bc6
--- /dev/null
+++ b/app-editors/ghex/ghex-43.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="GNOME hexadecimal editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Ghex"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/ghex.git"
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2+ FDL-1.1+"
+IUSE="gtk-doc test"
+RESTRICT="!test? ( test )"
+SLOT="4"
+
+RDEPEND="
+ >=dev-libs/glib-2.68.0:2
+ >=gui-libs/gtk-4.4.0:4
+ gui-libs/libadwaita:1
+ dev-libs/gobject-introspection
+ !app-editors/ghex:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? ( dev-util/gi-docgen )
+ test? (
+ dev-util/desktop-file-utils
+ dev-libs/appstream-glib
+ )
+ dev-util/gtk-update-icon-cache
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}"/usr/share/gtk-doc/
+ -Ddevelopment=false
+ -Dmmap-buffer-backend=true
+ -Ddirect-buffer-backend=true
+ -Dintrospection=enabled
+ $(meson_use gtk-doc gtk_doc)
+ -Dstatic-html-help=false
+ -Dvapi=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}