summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-06-13 20:41:22 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-06-13 20:41:54 +0300
commite89a9aa97ac41e347b7ee7b4fc749cb91accd223 (patch)
treef9d2d53ee6a606e18d6726d5189da9ada302d1a8 /app-editors
parentkde-apps/konqueror: drop 23.08.5 (diff)
downloadgentoo-e89a9aa97ac41e347b7ee7b4fc749cb91accd223.tar.gz
gentoo-e89a9aa97ac41e347b7ee7b4fc749cb91accd223.tar.bz2
gentoo-e89a9aa97ac41e347b7ee7b4fc749cb91accd223.zip
app-editors/vscode: add 1.90.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vscode/Manifest3
-rw-r--r--app-editors/vscode/vscode-1.90.1.ebuild132
2 files changed, 135 insertions, 0 deletions
diff --git a/app-editors/vscode/Manifest b/app-editors/vscode/Manifest
index 29f2ec87b845..2f4a73beb911 100644
--- a/app-editors/vscode/Manifest
+++ b/app-editors/vscode/Manifest
@@ -7,3 +7,6 @@ DIST vscode-1.89.1-arm64.tar.gz 139443388 BLAKE2B 4a88f080b631688a969160b002d47b
DIST vscode-1.90.0-amd64.tar.gz 143930997 BLAKE2B cc855974d718f32536ff663c4ee25479810154aa1820384ebdfd1bd2ad0958b2b54a160a7167f602535f621a061bf6d77495a28a06ae51f052e959ffae58ecf3 SHA512 4ba8513a14e9a579154fc7300ef3766e025fcd3faa21fc0806abe6d7ce5983984a7bd6bb157746e2e8e5de877cf537ebbea1b1c692489a1560fdccdef255f3c1
DIST vscode-1.90.0-arm.tar.gz 128877927 BLAKE2B 2a7869239c6743c750d43bc0b7a9d11788854e9e30116e9df341d0ed919292dde6e5a1cb12d9796872f26b3891ef36402117834ee23c935ad2651d897c878582 SHA512 2603ab8e2a36ae04f7e31dca4f1413d514625df2b8a9a193dc88c0b6d0776a532bc850f987e220ac9b49576f9e45e341fe02d708e6f74566219adb0de9386e8c
DIST vscode-1.90.0-arm64.tar.gz 140685043 BLAKE2B 7433f4b5562eb942013abc58c8bc1161694d0f21cebd307f9811fcf513926cfad44bf02caba38ea24c471c311b3c497ec59c487cfdc4ad29ddb22402f640df5e SHA512 cd41d8856f0979c7e9850abb3106c8fdac42946090a2e66f657f5a65cec002df0b84c9e6ee7d1f4ae302a2d29963bdc6f80d8c6978de3b4469a2b3e367227df7
+DIST vscode-1.90.1-amd64.tar.gz 143929144 BLAKE2B 22d8eb40647b8e91e6f09962b76a48944d6afd497385650bf3c153a0be763a643fbc1e1ba8d6468d9731b68a571d289e17e855b7081ad716fb1441b8a3e5478c SHA512 1288beb684918f831b887a3f0386ec5a5ce4c1140355bf835610221e09d566101bdc5f77734b0786aceda82500775f8adcbc09ce50b3ddc65dd3f74815032198
+DIST vscode-1.90.1-arm.tar.gz 128878947 BLAKE2B aceccb3ba1ba658a5378d582a662b7ebebb194a54d26107a7a7d0696a0d04416222a6d74d50966f8d8b2c7ee355ac3a8649e01d75d6a3294d6b4384442971e3e SHA512 e9bd3aa12d07e0ab7ff40fc89e5cbd2a8ed3e1e655a709b91016352ee7c800a52fe952a1069f67b5dd9b1801117ba9d2c1594c0c5706ad61cdd73c4c47ca1660
+DIST vscode-1.90.1-arm64.tar.gz 140679137 BLAKE2B c9f683d2140819c309f078bbe1f5fd38887202c52ec4158e7a02f661be1d92bccade18b409b3461135823a184a57adcc4e7b309d23ae7ac731e5adcbe736714c SHA512 71e23f79e880443dc18cef358fd08e43cb0640364d96c08bda3f05a9d87b2d68b44acfb5f9a01943dc89110962246c4f92ebdfda5c2498efa383551a62f44689
diff --git a/app-editors/vscode/vscode-1.90.1.ebuild b/app-editors/vscode/vscode-1.90.1.ebuild
new file mode 100644
index 000000000000..f803279f6a02
--- /dev/null
+++ b/app-editors/vscode/vscode-1.90.1.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+DESCRIPTION="Multiplatform Visual Studio Code from Microsoft"
+HOMEPAGE="https://code.visualstudio.com"
+SRC_URI="
+ amd64? ( https://update.code.visualstudio.com/${PV}/linux-x64/stable -> ${P}-amd64.tar.gz )
+ arm? ( https://update.code.visualstudio.com/${PV}/linux-armhf/stable -> ${P}-arm.tar.gz )
+ arm64? ( https://update.code.visualstudio.com/${PV}/linux-arm64/stable -> ${P}-arm64.tar.gz )
+"
+S="${WORKDIR}"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ Microsoft-vscode
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* amd64 ~arm ~arm64"
+IUSE="egl kerberos wayland"
+RESTRICT="mirror strip bindist"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ app-misc/ca-certificates
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/libcanberra[gtk3]
+ media-libs/libglvnd
+ media-libs/mesa
+ net-misc/curl
+ sys-apps/dbus
+ sys-libs/zlib
+ sys-process/lsof
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+ x11-misc/xdg-utils
+ kerberos? ( app-crypt/mit-krb5 )
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ if use amd64; then
+ cd "${WORKDIR}/VSCode-linux-x64" || die
+ elif use arm; then
+ cd "${WORKDIR}/VSCode-linux-armhf" || die
+ elif use arm64; then
+ cd "${WORKDIR}/VSCode-linux-arm64" || die
+ else
+ die "Visual Studio Code only supports amd64, arm and arm64"
+ fi
+
+ # Cleanup
+ rm -r ./resources/app/ThirdPartyNotices.txt || die
+
+ # Disable update server
+ sed -e "/updateUrl/d" -i ./resources/app/product.json || die
+
+ if ! use kerberos; then
+ rm -r ./resources/app/node_modules.asar.unpacked/kerberos || die
+ fi
+
+ # Install
+ pax-mark m code
+ mkdir -p "${ED}/opt/${PN}" || die
+ cp -r . "${ED}/opt/${PN}" || die
+ fperms 4711 /opt/${PN}/chrome-sandbox
+
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/vscode"
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/code"
+
+ local EXEC_EXTRA_FLAGS=()
+ if use wayland; then
+ EXEC_EXTRA_FLAGS+=( "--ozone-platform-hint=auto" "--enable-wayland-ime" )
+ fi
+ if use egl; then
+ EXEC_EXTRA_FLAGS+=( "--use-gl=egl" )
+ fi
+
+ sed "s|@exec_extra_flags@|${EXEC_EXTRA_FLAGS[*]}|g" \
+ "${FILESDIR}/code-url-handler.desktop" \
+ > "${T}/code-url-handler.desktop" || die
+
+ sed "s|@exec_extra_flags@|${EXEC_EXTRA_FLAGS[*]}|g" \
+ "${FILESDIR}/code.desktop" \
+ > "${T}/code.desktop" || die
+
+ domenu "${T}/code.desktop"
+ domenu "${T}/code-url-handler.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscode.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "desktop notifications" x11-libs/libnotify
+ optfeature "keyring support inside vscode" "virtual/secret-service"
+}