summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <nils.freydank@posteo.de>2020-07-06 14:23:29 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-07-15 11:06:35 +0300
commitfa9c0578834920ce97d7df190adeb51929b56ecf (patch)
tree21329f6cf826d2d571c6cf9eacfa7f1089c24b2c /app-editors
parentdev-python/markups: Support python3_9 and add dep for highlighting (diff)
downloadgentoo-fa9c0578834920ce97d7df190adeb51929b56ecf.tar.gz
gentoo-fa9c0578834920ce97d7df190adeb51929b56ecf.tar.bz2
gentoo-fa9c0578834920ce97d7df190adeb51929b56ecf.zip
app-editors/retext: Bump to 7.1.0 and support python3_9
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Nils Freydank <holgersson@posteo.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/retext/Manifest1
-rw-r--r--app-editors/retext/retext-7.1.0.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/app-editors/retext/Manifest b/app-editors/retext/Manifest
index 41d1bf735cf3..11c08166a6bc 100644
--- a/app-editors/retext/Manifest
+++ b/app-editors/retext/Manifest
@@ -1 +1,2 @@
DIST ReText-7.0.4.tar.gz 402934 BLAKE2B bae66a5fb8e81192d692d1a239706e2feee6ee940685cffdf3498880b2c9bd67cc85c6150e372a383e4bad13da210426fff95c06b2861b58020c2c6d298cf5d2 SHA512 cb12666b15414f4bf83f3b07c94d3bcba13dd3e6c3832c66520bfe8caafeeb87cc083a1e74530d98d6e00a00363add55fdf873e6de385e637876454130deebb3
+DIST ReText-7.1.0.tar.gz 484989 BLAKE2B 74f07218cba1d76d011e5347c65ec03ef84da29119c177f35cca206cb269ae4755fdb85448562a378d2ab610930d23b4eccb62a39807409c6e80a68102be2034 SHA512 92333f31f7a57440d642246ed30156384285bb44640a0d6e7654e82749681893eaef3cb16e41fa2d7b618aa59f1ea8cb07d431736b00f35cb9130d7294e3d105
diff --git a/app-editors/retext/retext-7.1.0.ebuild b/app-editors/retext/retext-7.1.0.ebuild
new file mode 100644
index 000000000000..f06ff35ad247
--- /dev/null
+++ b/app-editors/retext/retext-7.1.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# no pypy{,3} support as PyQt5 does not support it at 2020-07-05 (towelday)
+# https://bitbucket.org/pypy/compatibility/wiki/Home#!gui-library-bindings
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1 virtualx xdg-utils
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+MY_PN="ReText"
+MY_P="${MY_PN}-${PV/_/~}"
+
+DESCRIPTION="Simple editor for Markdown and reStructuredText"
+HOMEPAGE="https://github.com/retext-project/retext https://github.com/retext-project/retext/wiki"
+
+if [[ ${PV} == *9999 ]]
+ then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/retext-project/retext.git"
+ else
+ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}"/${MY_P}
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+spell"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/markups[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/python-markdown-math[${PYTHON_USEDEP}]
+ dev-python/PyQt5[gui,network,printsupport,widgets,${PYTHON_USEDEP}]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ spell? ( dev-python/pyenchant[${PYTHON_USEDEP}] )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ einfo "Starting with retext-7.0.4 the markdown-math plugin is installed."
+ einfo "Note that you can use different math delimiters, e.g. \(...\) for inline math."
+ einfo "For more details take a look at:"
+ einfo "https://github.com/mitya57/python-markdown-math#math-delimiters"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}