summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-05-04 14:48:01 +0200
committerUlrich Müller <ulm@gentoo.org>2019-05-04 15:33:38 +0200
commitdb8063cba7def8f0f8b8596b281511646b9699df (patch)
treecfd01cefe5494221ae7536789464029a4624d6e7 /app-emacs/async/async-1.9.3.ebuild
parentapp-portage/elt-patches: keyword ~riscv (diff)
downloadgentoo-db8063cba7def8f0f8b8596b281511646b9699df.tar.gz
gentoo-db8063cba7def8f0f8b8596b281511646b9699df.tar.bz2
gentoo-db8063cba7def8f0f8b8596b281511646b9699df.zip
app-emacs/async: Initial import.
Needed as dependency for app-emacs/helm. Ebuild contributed by me. Package-Manager: Portage-2.3.65, Repoman-2.3.12 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/async/async-1.9.3.ebuild')
-rw-r--r--app-emacs/async/async-1.9.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/async/async-1.9.3.ebuild b/app-emacs/async/async-1.9.3.ebuild
new file mode 100644
index 000000000000..c59fc3c4339d
--- /dev/null
+++ b/app-emacs/async/async-1.9.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+MY_P="emacs-async-${PV}"
+DESCRIPTION="Simple library for asynchronous processing in Emacs"
+HOMEPAGE="https://github.com/jwiegley/emacs-async"
+SRC_URI="https://github.com/jwiegley/emacs-async/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${MY_P}"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}