summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-05-20 00:50:53 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-05-20 01:14:04 +0200
commita136163c4581c547a31ccec219a9eaf76f5ad4cc (patch)
tree826448c05646efabf0600ba90990f4c72009f1b2 /app-emacs/consult
parentapp-emacs/embark: bump to 1.1 (diff)
downloadgentoo-a136163c4581c547a31ccec219a9eaf76f5ad4cc.tar.gz
gentoo-a136163c4581c547a31ccec219a9eaf76f5ad4cc.tar.bz2
gentoo-a136163c4581c547a31ccec219a9eaf76f5ad4cc.zip
app-emacs/consult: bump to 1.6
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/consult')
-rw-r--r--app-emacs/consult/Manifest1
-rw-r--r--app-emacs/consult/consult-1.6.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/consult/Manifest b/app-emacs/consult/Manifest
index 1e3566d6db4f..456ff0cb4f0a 100644
--- a/app-emacs/consult/Manifest
+++ b/app-emacs/consult/Manifest
@@ -1,2 +1,3 @@
DIST consult-1.4.tar.gz 103709 BLAKE2B 5326856b6bafc0a52d525971d84bd2fd3e0450aa1e8060d9ad49dabc6620fb2b721e5a26ba8d219bd889723109af766ba7fb8faa510301031f9372c798a8853d SHA512 4721820d288a357ea3432a850556a85cb037c1ddc262cada62d75e80641f1b402dd6edfceabb89b8dc386ae391081e02d2550f8773f9760ae267f3af8e381cb6
DIST consult-1.5.tar.gz 103884 BLAKE2B 3244582f7b5db6e17ef8b42d1482088c263fce02124596728c3afa17673a1e17565b82b2ba37a6843af72279cf36df49febda389c42d5a6c6be8a7a0ca3ad05f SHA512 2e2b96a7bb6b0a311796a76a1f5609f4c7ad48eb1d3c98c6431aeec1803222c437a552483f198de7d195e5a4cded79e00b673382a9cfbefe18864fa2d170f2bf
+DIST consult-1.6.tar.gz 104127 BLAKE2B 97a8cdc96618ce5a4e0734b0a60ff9c4e9237230fc45115ae1f8ed2bdecacbdd640b9a2078c3a3e20c51b7535ff87a3f23538079e711c264d9131f0df9d388c3 SHA512 7595ef20232875d177354a7f39034f5c2b3b5e5f0a22674e697c1a653085d6fbe8ffdea0696f24a07656509f3fd4941fc34eef948cdead1c6df90dc0acba2b48
diff --git a/app-emacs/consult/consult-1.6.ebuild b/app-emacs/consult/consult-1.6.ebuild
new file mode 100644
index 000000000000..7f3ed9bf0123
--- /dev/null
+++ b/app-emacs/consult/consult-1.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27
+
+inherit elisp
+
+DESCRIPTION="Consulting complete-read for GNU Emacs"
+HOMEPAGE="https://github.com/minad/consult/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-28.1
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}