summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-08 18:12:57 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-08 18:42:41 +0100
commit14b0730a339990a3729f20c2149ca1a34e4b294f (patch)
tree3f895fa34ddbe58cad30ac59559ad6723dd02bd2 /app-emacs/denote
parentnet-libs/libiscsi: Stabilize 1.19.0_p20230208 x86, #786987 (diff)
downloadgentoo-14b0730a339990a3729f20c2149ca1a34e4b294f.tar.gz
gentoo-14b0730a339990a3729f20c2149ca1a34e4b294f.tar.bz2
gentoo-14b0730a339990a3729f20c2149ca1a34e4b294f.zip
app-emacs/denote: new package, add 2.1.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/denote')
-rw-r--r--app-emacs/denote/Manifest1
-rw-r--r--app-emacs/denote/denote-2.1.0.ebuild39
-rw-r--r--app-emacs/denote/files/50denote-gentoo.el2
-rw-r--r--app-emacs/denote/metadata.xml20
4 files changed, 62 insertions, 0 deletions
diff --git a/app-emacs/denote/Manifest b/app-emacs/denote/Manifest
new file mode 100644
index 000000000000..1d29620d2949
--- /dev/null
+++ b/app-emacs/denote/Manifest
@@ -0,0 +1 @@
+DIST denote-2.1.0.tar.gz 194241 BLAKE2B 2d3a279f99bbaa7d924c17b4df960f725fa548a5f809c51abea9f8c66c2e7bbba0cc3bfe1d71fb187542f5acc7f8272ea14f352b6122872bdbc41a7110660adc SHA512 5f36e7a2b6802fa9623226318762a06fc542589773a4441d19b02efe2e75c04753971726029150ddba8faf5a56c5030239f09c4942757ad7f7374c1ca587b390
diff --git a/app-emacs/denote/denote-2.1.0.ebuild b/app-emacs/denote/denote-2.1.0.ebuild
new file mode 100644
index 000000000000..244dcb96f2d8
--- /dev/null
+++ b/app-emacs/denote/denote-2.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=28.1
+
+inherit elisp
+
+DESCRIPTION="Simple notes for Emacs with an efficient file-naming scheme"
+HOMEPAGE="https://protesilaos.com/emacs/denote/
+ https://github.com/protesilaos/denote/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/protesilaos/${PN}.git"
+else
+ SRC_URI="https://github.com/protesilaos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+RESTRICT="test" # Some tests fail.
+
+DOCS=( CHANGELOG.org README.md )
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert tests
+
+src_compile() {
+ elisp-org-export-to texinfo README.org
+ elisp_src_compile
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/denote/files/50denote-gentoo.el b/app-emacs/denote/files/50denote-gentoo.el
new file mode 100644
index 000000000000..a11724713f3f
--- /dev/null
+++ b/app-emacs/denote/files/50denote-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "denote-autoloads" nil t)
diff --git a/app-emacs/denote/metadata.xml b/app-emacs/denote/metadata.xml
new file mode 100644
index 000000000000..d564aa6e7d59
--- /dev/null
+++ b/app-emacs/denote/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Denote is a simple note-taking tool for Emacs. It is based on the idea that
+ notes should follow a predictable and descriptive file-naming scheme. The
+ file name must offer a clear indication of what the note is about, without
+ reference to any other metadata. Denote basically streamlines the creation
+ of such files while providing facilities to link between them.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/protesilaos/denote/issues/</bugs-to>
+ <remote-id type="github">protesilaos/denote</remote-id>
+ </upstream>
+</pkgmetadata>