summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-03-26 01:34:47 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-03-26 01:35:21 +0100
commit013161e35c4cfcc47f00640178b9088251e24d16 (patch)
tree0dcaf8b4a3017f4577c61e1a80e3e60625091628 /app-emacs/emacs-ebuild-snippets
parentapp-emacs/emacs-ebuild-snippets: enable live (diff)
downloadgentoo-013161e35c4cfcc47f00640178b9088251e24d16.tar.gz
gentoo-013161e35c4cfcc47f00640178b9088251e24d16.tar.bz2
gentoo-013161e35c4cfcc47f00640178b9088251e24d16.zip
app-emacs/emacs-ebuild-snippets: add live 9999 version
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/emacs-ebuild-snippets')
-rw-r--r--app-emacs/emacs-ebuild-snippets/emacs-ebuild-snippets-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/emacs-ebuild-snippets/emacs-ebuild-snippets-9999.ebuild b/app-emacs/emacs-ebuild-snippets/emacs-ebuild-snippets-9999.ebuild
new file mode 100644
index 000000000000..4d5a6435a1cf
--- /dev/null
+++ b/app-emacs/emacs-ebuild-snippets/emacs-ebuild-snippets-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Yasnippets for editing ebuilds and eclasses"
+HOMEPAGE="https://gitweb.gentoo.org/proj/emacs-ebuild-snippets.git"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitweb.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/ebuild-mode
+ app-emacs/yasnippet
+"
+BDEPEND="${RDEPEND}"
+
+src_prepare() {
+ sh ./scripts/changeme.sh "${EPREFIX}${SITEETC}/${PN}" || die
+
+ default
+}
+
+src_install() {
+ elisp-install ${PN} *.el{,c}
+ elisp-site-file-install "${S}"/gentoo/50${PN}-gentoo.el
+
+ insinto "${SITEETC}/${PN}"
+ doins -r snippets
+}