summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-06-14 10:29:15 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-06-14 10:39:57 +0200
commitdac11cbc9d1855568fb6818cf49224ea632c7d96 (patch)
tree197f724c8a3723c8a366ecb2ef9dc2e5105c407b /app-emacs/lv/lv-0.15.0-r1.ebuild
parentapp-emacs/dap-mode: add missing hydra dep (diff)
downloadgentoo-dac11cbc9d1855568fb6818cf49224ea632c7d96.tar.gz
gentoo-dac11cbc9d1855568fb6818cf49224ea632c7d96.tar.bz2
gentoo-dac11cbc9d1855568fb6818cf49224ea632c7d96.zip
app-emacs/lv: do not install hydra
lv also installed hydra which is shared in that project, hydra and lv are broken into separate packages Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/lv/lv-0.15.0-r1.ebuild')
-rw-r--r--app-emacs/lv/lv-0.15.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/lv/lv-0.15.0-r1.ebuild b/app-emacs/lv/lv-0.15.0-r1.ebuild
new file mode 100644
index 000000000000..0a3a7b98401b
--- /dev/null
+++ b/app-emacs/lv/lv-0.15.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Other echo area"
+HOMEPAGE="https://github.com/abo-abo/hydra/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/abo-abo/hydra.git"
+else
+ SRC_URI="https://github.com/abo-abo/hydra/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/hydra-${PV}"
+ KEYWORDS="amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile lv.el
+}
+
+src_install() {
+ elisp-install lv lv.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}