summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-20 14:41:05 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-20 20:45:47 +0100
commit2fbc7f9e1f252cbaafaca434098a591484aeeb96 (patch)
tree97d12c9f330af0af21d6a398b7b18475591dd404 /app-emacs/package-lint
parentapp-emacs/package-lint: drop old 0.20 (diff)
downloadgentoo-2fbc7f9e1f252cbaafaca434098a591484aeeb96.tar.gz
gentoo-2fbc7f9e1f252cbaafaca434098a591484aeeb96.tar.bz2
gentoo-2fbc7f9e1f252cbaafaca434098a591484aeeb96.zip
app-emacs/package-lint: add new dependency for 0.21 - compat
Closes: https://bugs.gentoo.org/920378 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/package-lint')
-rw-r--r--app-emacs/package-lint/package-lint-0.21-r1.ebuild51
-rw-r--r--app-emacs/package-lint/package-lint-0.21.ebuild35
2 files changed, 51 insertions, 35 deletions
diff --git a/app-emacs/package-lint/package-lint-0.21-r1.ebuild b/app-emacs/package-lint/package-lint-0.21-r1.ebuild
new file mode 100644
index 000000000000..995c84ec579c
--- /dev/null
+++ b/app-emacs/package-lint/package-lint-0.21-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Linting library for Emacs Lisp package metadata"
+HOMEPAGE="https://github.com/purcell/package-lint/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/purcell/${PN}.git"
+else
+ SRC_URI="https://github.com/purcell/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/compat
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-symbol-info-data-directory.patch" )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed "s|@SITEETC@|${EPREFIX}${SITEETC}/${PN}|" -i "${PN}.el" || die
+}
+
+src_install() {
+ elisp-install "${PN}" ${PN}{,-flymake}.el{,c}
+ elisp-make-site-file "${SITEFILE}"
+
+ insinto "${SITEETC}/${PN}"
+ doins -r data
+
+ einstalldocs
+}
diff --git a/app-emacs/package-lint/package-lint-0.21.ebuild b/app-emacs/package-lint/package-lint-0.21.ebuild
deleted file mode 100644
index 4f573a3330fa..000000000000
--- a/app-emacs/package-lint/package-lint-0.21.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-NEED_EMACS=26.1
-
-inherit elisp
-
-DESCRIPTION="Linting library for Emacs Lisp package metadata"
-HOMEPAGE="https://github.com/purcell/package-lint/"
-SRC_URI="https://github.com/purcell/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-
-PATCHES=( "${FILESDIR}"/${PN}-symbol-info-data-directory.patch )
-SITEFILE="50${PN}-gentoo.el"
-
-src_prepare() {
- elisp_src_prepare
-
- sed "s|@SITEETC@|${EPREFIX}${SITEETC}/${PN}|" -i ${PN}.el || die
-}
-
-src_install() {
- elisp-install ${PN} ${PN}{,-flymake}.el{,c}
- elisp-make-site-file "${SITEFILE}"
-
- insinto ${SITEETC}/${PN}
- doins -r data
-
- einstalldocs
-}