summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-03-08 18:01:58 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-03-08 18:01:58 +0100
commit22ac1ea5e06b565667582189b917815dccd49ec4 (patch)
tree9ae6673fd4cd5db4fe99c8341cd3cd061a394abc /app-emacs/rust-mode/rust-mode-1.0.4.ebuild
parentros-meta/ros_comm: Bump to 1.15.14. (diff)
downloadgentoo-22ac1ea5e06b565667582189b917815dccd49ec4.tar.gz
gentoo-22ac1ea5e06b565667582189b917815dccd49ec4.tar.bz2
gentoo-22ac1ea5e06b565667582189b917815dccd49ec4.zip
app-emacs/rust-mode: bump to 1.0.4
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/rust-mode/rust-mode-1.0.4.ebuild')
-rw-r--r--app-emacs/rust-mode/rust-mode-1.0.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/rust-mode/rust-mode-1.0.4.ebuild b/app-emacs/rust-mode/rust-mode-1.0.4.ebuild
new file mode 100644
index 000000000000..bd23bef33b88
--- /dev/null
+++ b/app-emacs/rust-mode/rust-mode-1.0.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="A major emacs mode for editing Rust source code"
+HOMEPAGE="https://github.com/rust-lang/rust-mode"
+SRC_URI="https://github.com/rust-lang/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} \
+ -l rust-mode.el -l rust-mode-tests.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}